Bug 481075 - udev gets errors on update and ends up not runnig
udev gets errors on update and ends up not runnig
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 20:38 EST by Michal Jaegermann
Modified: 2009-07-22 17:44 EDT (History)
1 user (show)

See Also:
Fixed In Version: 141-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 17:44:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2009-01-21 20:38:19 EST
Description of problem:

The following showed up on update:

  Updating       : udev                                                  79/164 
error binding control socket, seems udevd is already running
groupadd: GID 87 is not unique

I am not sure about the first error.  Timing?  I see in package scripts

        if [ -n "$pid" ]; then
                kill $pid
                /sbin/udevd -d
        fi

but the net result was that udevd was not running and had to be restarted.

"groupadd: GID 87 is not unique" is correct because PolicyKit package already did "/usr/sbin/useradd -c 'PolicyKit' -u 87 ..." and there is "polkituser:x:87:" in /etc/group.

Version-Release number of selected component (if applicable):
udev-136-2.fc11
Comment 1 Harald Hoyer 2009-01-22 04:26:55 EST
the groupadd is bug #480795

hmm, strange.. the other problem is new
Comment 2 Michal Jaegermann 2009-01-22 12:08:31 EST
> hmm, strange.. the other problem is new

I was scratching my head too because if I am running relevant parts of scripts from a command line then everything works like expected.  Maybe indeed some timing?  'udevd' was killed, eventually but long before I had a chance to check, only not to be restarted.  Would be beneficial to have a short 'sleep' after 'kill' or something else may hold it?

I presume that it is not possible to have multiple instances of 'udevd' running in some circumstances.  Or this indeed may happen?
Comment 3 Michal Jaegermann 2009-01-31 18:04:08 EST
An update to udev-137-2.fc11 got the same "error binding control socket, seems udevd is already running" and 'pgrep -f -l udev' after an update comes back empty 
but it shows a running one after '/sbin/udevd -d'.

It appears that the previous instance of udevd prevents the new one from starting and gets later killed in a "preuninstall" script when yum is in a cleanup phase. Just guessing ....

At least 'dialout' group moved to 18 and it does not clash with some other GID. :-)
Comment 4 Harald Hoyer 2009-02-02 04:59:17 EST
I'll try to make the %post section more hardened against that...
Comment 5 Bug Zapper 2009-06-09 06:49:25 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Fedora Update System 2009-06-30 08:05:32 EDT
udev-141-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/udev-141-4.fc11
Comment 7 Fedora Update System 2009-07-02 01:45:32 EDT
udev-141-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update udev'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7208
Comment 8 Fedora Update System 2009-07-22 17:44:05 EDT
udev-141-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.