Bug 481093 - ibus causes pidgin to crash
ibus causes pidgin to crash
Status: CLOSED DUPLICATE of bug 481693
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 481098
  Show dependency treegraph
 
Reported: 2009-01-21 23:15 EST by Warren Togami
Modified: 2009-02-03 04:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-03 04:53:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pidgin crash backtrace (13.97 KB, text/plain)
2009-01-26 21:57 EST, Warren Togami
no flags Details

  None (edit)
Description Warren Togami 2009-01-21 23:15:21 EST
ibus-0.1.1.20081023-2.fc10.x86_64
ibus-anthy-0.1.1.20080912-1.fc10.x86_64
pidgin-2.5.4-1.fc10.x86_64
LANG=en_US.utf8

ibus IM causes pidgin to occasionally crash.  Happens unpredictably it is difficult to reproduce on demand.  We need good reports with full debuginfo crash dumps and what you were doing at the time of the crash.

debuginfo-install pidgin ibus bug-buddy

http://people.redhat.com/wtogami/temp/pidgin-bugreport.txt
Here is an incomplete crash dump.  Sadly I did not have ibus*debuginfo installed at the time.  Will have more complete dumps later.
Comment 1 Warren Togami 2009-01-26 21:57:43 EST
Created attachment 330056 [details]
pidgin crash backtrace

pidgin-2.5.4-1.fc10.x86_64
ibus-0.1.1.20081023-2.fc10.x86_64
imsettings-0.105.1-2.fc10.x86_64

1. Disconnect and reconnect imsettings.
2. Start pidgin.
3. Pop-up a dialog window to chat with anyone.
4. Crash.
Comment 2 Warren Togami 2009-01-26 22:35:07 EST
Ugh, reconnecting doesn't definitively allow this problem to be reproducible.

It seems to happen after login (but not all the time).  Several GTK+ applications like pidgin or gramps crash while popping up certain dialog windows.  Then something else unknown seems to change state and thereafter it no longer crashes.
Comment 3 Peng Huang 2009-02-03 04:53:46 EST

*** This bug has been marked as a duplicate of bug 481693 ***

Note You need to log in before you can comment on or make changes to this bug.