Bug 481693 - Application start failed (after input method change to ibus)
Application start failed (after input method change to ibus)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
: 481093 (view as bug list)
Depends On:
Blocks: 481098
  Show dependency treegraph
 
Reported: 2009-01-27 00:23 EST by bucchie73
Modified: 2009-02-04 21:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 21:21:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xsession-errors (2.58 KB, text/plain)
2009-01-27 00:26 EST, bucchie73
no flags Details
backtrace (16.06 KB, text/plain)
2009-01-27 11:14 EST, bucchie73
no flags Details

  None (edit)
Description bucchie73 2009-01-27 00:23:58 EST
Description of problem:Application start failed (after input method change to ibus)


Version-Release number of selected component (if applicable):ibus-0.1.1.20081023-2.fc10.x86_64


How reproducible:


Steps to Reproduce:
1.input method change from scim to ibus
2.reboot
3.after login,select 'application'-'system-tool'-'gnome-terminal' or 'application'-'internet'-'firefox'
  
Actual results:sometimes application start failed.


Expected results:


Additional info:It is not generated every time.
Comment 1 bucchie73 2009-01-27 00:26:37 EST
Created attachment 330063 [details]
xsession-errors

xsession-errors when firefox start failed.
Comment 2 bucchie73 2009-01-27 11:14:46 EST
Created attachment 330105 [details]
backtrace

when crash gnome-terminal
Comment 3 bucchie73 2009-01-27 11:37:31 EST
The problem does not occur when I return it to SCIM.
Comment 4 Peng Huang 2009-02-02 22:06:41 EST
Hi bucchie73,
I have a test build for ibus in koji. It might fix this problem. Please try it. Thanks.

http://koji.fedoraproject.org/koji/taskinfo?taskID=1100488
Comment 5 bucchie73 2009-02-03 00:19:28 EST
I tried these test packages in koji, it seems to work very fine.

It was not a big problem, but I was not able to install ibus-gtk.i386
---------------------------------------------------------------
Error: Missing Dependency: libibus-gtk.so.0 is needed by package ibus-gtk-0.1.1.20090203-1.fc10.i386
Comment 6 Peng Huang 2009-02-03 00:30:34 EST
You should download all rpms (ibus, ibus-gtk, ibus-qt) and update them together. 
BTW, I think your system is x86_64. You need download rpms suffixes with x86_64.rpm
Comment 7 bucchie73 2009-02-03 01:05:08 EST
I am sorry to write a sentence causing misunderstanding.

I installed these packages.

ibus-0.1.1.20090203-1.fc10.x86_64
ibus-debuginfo-0.1.1.20090203-1.fc10.x86_64
ibus-gtk-0.1.1.20090203-1.fc10.x86_64
ibus-qt-0.1.1.20090203-1.fc10.x86_64

It seems to work very fine.

I was able to install ibus-gtk-0.1.1.20081023-2.fc10.i386 before I updated it, 
but was not able to install ibus-gtk-0.1.1.20090203-1.fc10.i386 now.

Is there any change?
Comment 8 Peng Huang 2009-02-03 04:36:53 EST
You downloaded ibus's spec file has some problem. But it is not a big deal. I have fixed it. If you want, you could re-install ibus-gtk.i386 from  fedora update repo.
Comment 9 Peng Huang 2009-02-03 04:37:53 EST
Fixed in 0.1.1.20090203-1
Comment 10 bucchie73 2009-02-03 04:41:56 EST
Now I tried new build in koji.

http://koji.fedoraproject.org/koji/buildinfo?buildID=81323

I could install ibus-gtk-0.1.1.20090203-1.fc10.i386 now,
and all the problems were solved.

Thank you!
Comment 11 Peng Huang 2009-02-03 04:53:46 EST
*** Bug 481093 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Update System 2009-02-04 21:21:06 EST
ibus-0.1.1.20090203-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.