Bug 481154 - Sporadic change of keyboard to a "bad"/slow state
Sporadic change of keyboard to a "bad"/slow state
Status: CLOSED DUPLICATE of bug 445898
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Depends On:
  Show dependency treegraph
Reported: 2009-01-22 09:11 EST by Pat Gunn
Modified: 2009-02-25 18:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-27 20:56:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Pat Gunn 2009-01-22 09:11:03 EST
Description of problem:
Every few days, I've had Xorg suddenly transition to a bad keyboard state, where all keys need to be held down for about half a second in order to register (making typing very slow and difficult). Neither dmesg nor /var/log/Xorg.0.log show any unusual events. A bit of experimenting with xev shows that X doesn't even get the keystroke until after that half-a-second (these are all keystrokes, from control to the letter keys). Changing to a text console lets me type without any difficulty - switching back into the X session restores the unusable configuration. Starting a second X session from the console gives me a usable setup, as does logging out of the first session and letting it restart.

Version-Release number of selected component (if applicable):

How reproducible:
Limited. Problem occurs only every few days, and always when the system is active. It happens during normal use - if I notice any common threads that may lead to the problem I'll add them here.

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
System is a laptop. I have yet to try plugging in an additional USB keyboard to the system when this happens to see if it's affected.
Comment 1 Matěj Cepl 2009-01-23 12:49:32 EST
There is some problem with spontaneous switching on of the "Slow keys" accessibility. Run

gnome-keyboard-properties --a11y

and switch it off. Is that correct?
Comment 2 Pat Gunn 2009-01-23 13:00:39 EST
I'll try that the next time it happens, and let you know if it works. Thanks.
Comment 3 Matěj Cepl 2009-01-24 03:46:08 EST
*** Bug 479204 has been marked as a duplicate of this bug. ***
Comment 4 Pat Gunn 2009-01-27 10:25:08 EST
It happened again, and bringing up that panel, switching on slow keys, and then switching it off fixed the keyboard.

However, two things make me curious:
That panel did not think that slow keys was on, and only by toggling it on and then off was it fixed.
I don't normally run GNOME on my system (meaning no gnome-settings-daemon was running until I started gnome-keyboard-properties), so I'm a bit doubtful it was anything GNOME that set this.

It seems likely that the underlying mechanism gnome-keyboard-properties/GNOME is using is what was somehow triggered. I wonder if there's a way to disable that mechanism globally in X.
Comment 5 Matěj Cepl 2009-01-27 20:56:14 EST

*** This bug has been marked as a duplicate of bug 445898 ***
Comment 6 gareth foster 2009-02-25 18:23:31 EST
Has this got anything to do with the mouse cursor being corrupted and appearing as a big pile of pixels? Why was my bug closed and marked as a DUP?

Note You need to log in before you can comment on or make changes to this bug.