Bug 481196 - dosfslabel returns code 1 upon success.
dosfslabel returns code 1 upon success.
Status: CLOSED DUPLICATE of bug 468050
Product: Fedora
Classification: Fedora
Component: dosfstools (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Stepan Kasal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-22 12:42 EST by Luke Macken
Modified: 2016-09-19 22:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-29 11:19:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Macken 2009-01-22 12:42:33 EST
Description of problem:

The dosfslabel tool returns error code 1, even if it was successful.

The code is currently:

    return fs_close(rw) ? 1 : 0;

where fs_close returns 1 if something was written, and 0 else.

This test could be inverted as writing means success, but reading the
code I don't think it can fail anyway as neither write_label or fs_write
does any check so I think it could probably just always return 0.
Comment 1 Stepan Kasal 2009-01-29 11:19:16 EST

*** This bug has been marked as a duplicate of bug 468050 ***

Note You need to log in before you can comment on or make changes to this bug.