Bug 481212 - Initscript metadata parsing bug? (malformed header in lcdproc)
Initscript metadata parsing bug? (malformed header in lcdproc)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lcdproc (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Nicolas Chauvet (kwizart)
Fedora Extras Quality Assurance
:
: 481210 (view as bug list)
Depends On: 481198
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-22 14:40 EST by Eric Sandeen
Modified: 2009-05-20 19:58 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.5.2-12.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 481198
Environment:
Last Closed: 2009-05-20 19:57:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2009-01-22 14:40:36 EST
+++ This bug was initially created as a clone of Bug #481198 +++

The lcdproc0.5.2-7.fc10.x86_64 package contains initscripts with only the LSB-style metadata:

#### BEGIN INIT INFO
# Provides:          LCDd
# Required-Start:    $syslog $local_fs $network $remote_fs
# Required-Stop:     $syslog $local_fs $network $remote_fs
# Default-Start:     2 3 4 5
# Default-Stop:      S 0 1 6
# Short-Description: LCDproc Server Daemon
# Description:       LSB init script for LCDd, the display
#                    server daemon in the LCDproc suite
### END INIT INFO

When this is chkconfig --add'd, I get things like:

# ls /etc/rc3.d | grep -i lcd
S-1LCDd
S-1lcdproc

(not the dash) and also, the scripts are not visible via --list:

[root@mythbox ~]# chkconfig --list | grep lcdproc
[root@mythbox ~]#

If LSB-only metadata isn't supported, or if the format is wrong, we can bounce this to lcdproc, otherwise maybe this is a bug in initscripts?

--- Additional comment from esandeen@redhat.com on 2009-01-22 13:02:52 EDT ---

oops, "not the dash" was supposed to be "note the dash" :)

--- Additional comment from notting@redhat.com on 2009-01-22 14:05:11 EDT ---

"BEGIN INIT INFO" needs to have only 3 '#' marks, not 4.

Arguably, chkconfig should throw an error.

--- Additional comment from notting@redhat.com on 2009-01-22 14:23:13 EDT ---

http://git.fedorahosted.org/git/?p=chkconfig.git;a=commitdiff;h=e009cf65c2a44c027c970f4012e0ea7ad40ef65f

Will show up in rawhide at some point. lcdproc still needs fixed, of course.

--- Additional comment from esandeen@redhat.com on 2009-01-22 14:37:15 EDT ---

thanks, will file an lcdproc bug too.

-Eric
Comment 1 Bill Nottingham 2009-01-22 14:42:48 EST
*** Bug 481210 has been marked as a duplicate of this bug. ***
Comment 2 Nicolas Chauvet (kwizart) 2009-04-14 10:35:52 EDT
The problem is aimed to be fixed in lcdproc-0.5.2-11 (currently in rawhide only)
And will be backported in current release (F-10/F-9) in a week unless something wrong arise.
The default configuration is disabled in lcdproc initscript because ncurse isn't a relevant default driver. So initscripts will exit to 6 unless a user specific configuration file is created.
Comment 3 Fedora Update System 2009-04-26 05:33:41 EDT
lcdproc-0.5.2-11.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/lcdproc-0.5.2-11.fc9
Comment 4 Fedora Update System 2009-04-26 05:33:51 EDT
lcdproc-0.5.2-11.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/lcdproc-0.5.2-11.fc10
Comment 5 Fedora Update System 2009-04-27 17:19:50 EDT
lcdproc-0.5.2-11.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lcdproc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3903
Comment 6 Fedora Update System 2009-04-27 17:35:07 EDT
lcdproc-0.5.2-11.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update lcdproc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-4012
Comment 7 Fedora Update System 2009-05-13 12:56:40 EDT
lcdproc-0.5.2-12.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/lcdproc-0.5.2-12.fc10
Comment 8 Fedora Update System 2009-05-13 12:57:38 EDT
lcdproc-0.5.2-12.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/lcdproc-0.5.2-12.fc9
Comment 9 Fedora Update System 2009-05-15 19:30:31 EDT
lcdproc-0.5.2-12.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update lcdproc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-5012
Comment 10 Fedora Update System 2009-05-15 19:31:09 EDT
lcdproc-0.5.2-12.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lcdproc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-5016
Comment 11 Fedora Update System 2009-05-20 19:57:37 EDT
lcdproc-0.5.2-12.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-05-20 19:58:23 EDT
lcdproc-0.5.2-12.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.