Bug 481255 - phonon-backend-xine: phonon backend plugin could not be loaded (in gnome)
phonon-backend-xine: phonon backend plugin could not be loaded (in gnome)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: phonon (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On: kde42
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-22 23:41 EST by Richard Shaw
Modified: 2009-02-19 06:42 EST (History)
6 users (show)

See Also:
Fixed In Version: KDE 4.2.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-19 06:42:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Valgrind output of amarok (138.92 KB, application/octet-stream)
2009-01-25 23:45 EST, Richard Shaw
no flags Details

  None (edit)
Description Richard Shaw 2009-01-22 23:41:47 EST
Description of problem:
Amarok as installed could not play audio files (ogg specifically). All my systems are x86_64 but I would assume i386 would have the same issue.

Version-Release number of selected component (if applicable):
2.0.1.1-1.fc10

How reproducible:
So far, two out of two home computers.

Steps to Reproduce:
1. Install Fedora 10
2. yum install amarok
3.
  
Actual results:
No audio from ogg files (can't verify others as my library is almost entirely ogg vorbis)

Expected results:
Audio should work

Additional info:
I ran amarok from a terminal and saw a lot of output about various things but what caught my attention was something about not being able to load a phonon plugin. I did a "yum list phonon\*" and found that phonon and phonon-backend-xine were both installed but phonon-backend-gstreamer was not. After installing it audio worked as expected. I assume that this package should be a dependency for amarok.
Comment 1 Rex Dieter 2009-01-23 07:37:18 EST
phonon-backend-xine is default for a reason (gstreamer one still has various issues).  That said, if the gstreamer backend works for you, great.

We've had quite a few reports of gnome users unable to use the xine-backend, as you report here, but to date, have been unable to reproduce the problem.

In the meantime, if you'd be willing to help us diagnose, that would be great.

1. What DE are you using (gnome, kde, other)?

2.  Are you using PulseAudio?  if so, please verify that it is running and audio is otherwise playing ok.

3. what does this output:
rpm -q amarok phonon-backend-xine xine-lib-pulseaudio
Comment 2 Rex Dieter 2009-01-23 07:37:55 EST
and,

0.  yum groupupdate sound-and-video
does this command install anything new?  If so, what was previously missing?
Comment 3 Richard Shaw 2009-01-23 10:30:24 EST
1. Gnome

2. Yes. Audio works fine in almost all cases (MythTV still doesn't play nice). Programs that support Pulseaudio play fine and those that use the alsa plugin do fine as well. AC3 passthrough also functions as it should.

3. I'll have to get back to you on this one after work.

4. I'll try this when I get home but I don't expect it to do anything as this was a fresh install other than preserving my home directory from F9.
Comment 4 Richard Shaw 2009-01-25 09:09:16 EST
3. [richard@hobbes ~]$ rpm -q amarok phonon-backend-xine xine-lib-pulseaudio
amarok-2.0.1.1-1.fc10.x86_64
phonon-backend-xine-4.1.4-2.fc10.x86_64
xine-lib-pulseaudio-1.1.16-1.fc10.x86_64

4. Here's the packages it wants to install:

Installing:
 gstreamer-ffmpeg     x86_64 0.10.5-1.fc10         rpmfusion-free         156 k
 gstreamer-plugins-ugly
                      x86_64 0.10.10-2.fc10        rpmfusion-free-updates 319 k
 k3b-extras-freeworld x86_64 1.0.5-4.fc10          rpmfusion-free          64 k
 rhythmbox            x86_64 0.11.6-17.r6096.fc10  updates                4.5 M
Installing for dependencies:
 gstreamer-python     x86_64 0.10.12-1.fc10        fedora                 314 k
 libsidplay           x86_64 1.36.57-17            fedora                  91 k
---

I'm wondering if this is a byproduct of another bug[1][2] where using the pulseaudio xine library causes xine to segfault?

It looks like Lennart had a fix[2] for this on 12/16 but xine still segaults for me.

I went ahead with the groupupdate sound-and-video but xine still segfaults.

[1] https://bugzilla.rpmfusion.org/show_bug.cgi?id=125
[2] https://bugzilla.redhat.com/show_bug.cgi?id=473080
Comment 5 Rex Dieter 2009-01-25 09:21:35 EST
xine segfault should be addressed by xine-lib-1.1.16.1 update, 
https://admin.fedoraproject.org/updates/F10/FEDORA-2009-0884
for bug #480504

That said, I'm fairly certain that's a completely separate issue.

Do you have any other xine-lib-using apps to use as a test case?  (maybe with the aforementioned update, you could try xine again, or perhaps try kaffeine).
Comment 6 Richard Shaw 2009-01-25 09:27:44 EST
Well I tried Miro which uses Xine for playback and it worked fine...

The segault problem bothers me though since I'm updated to 1.1.16-1.FC10 and it's still happening.
Comment 7 Rex Dieter 2009-01-25 11:00:09 EST
Try xine-lib-1.1.16.1 (per comment #5)?
Comment 8 Richard Shaw 2009-01-25 11:49:21 EST
Sorry, got confused between .1 and -1. I updated and it pulled in a bunch of i386 files... 

Xine no longer segfaults but I removed phonon-backend-gstreamer to see if Amarok worked and I'm back to no audio.

Still getting the following errors:
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded 
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded 
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded 
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded 
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded 
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded 

I remember in older versions you could pick your playback engine but that options eems to no longer be available.
Comment 9 Rex Dieter 2009-01-25 12:01:37 EST
phonon now controls backend (it's no longer amarok specific): 
systemsettings -> multimedia

(systemsettings is in kdebase-workspace, if you don't happen to have that installed).

Now, to discover wtf is causing these: 
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin
could not be loaded 

(reassigning to phonon)
Comment 10 Kevin Kofler 2009-01-25 12:16:49 EST
SELinux problem?

Try:
su -c "setenforce 0"

If that helps, you can configure SELinux to permissive or disabled in system-config-selinux.
Comment 11 Richard Shaw 2009-01-25 18:28:14 EST
No luck with setenforce 0...  I'm running Gnome so I don't seem to have the setting app. Is there a way to do it from the command line?
Comment 12 Richard Shaw 2009-01-25 23:45:54 EST
Created attachment 329964 [details]
Valgrind output of amarok
Comment 13 Kevin Kofler 2009-01-26 04:27:15 EST
Unfortunately there's no useful information in that Valgrind log. So the bug does not look like a memory issue.
Comment 14 Richard Shaw 2009-01-26 08:58:49 EST
Yeah, I didn't see much in there either but I figured it was worth a try. Is there a way to get more useful output from Phonon?
Comment 15 Rex Dieter 2009-01-26 09:21:59 EST
adjusting summary, I'll ping some upstream folks for guidance.
Comment 16 Rex Dieter 2009-01-26 10:20:16 EST
After completely removing qt/kde, and re-installing only amarok under gnome, I was finally able to reproduce, esp with some additional adivce from #phonon, to run with evn var:  PHONON_DEBUG=1

Richard, try
yum install kdebase-runtime

Seems that phonon is supposed to be able to function without it, but (for whatever reason) doesn't atm.

In the meantime, we'll explore how to fix this properly.
Comment 17 Kevin Kofler 2009-01-26 10:37:47 EST
The xine-lib backend in KDE 4.1 is a KDE plugin. This should be fixed in KDE 4.2 / phonon 4.3 where it's a qt-only plugin (part of Phonon itself).
Comment 18 Rex Dieter 2009-01-26 11:01:57 EST
Woo, confirmed better/fixed with phonon-4.3.0 (coming with kde-4.2.0)
Comment 19 Rex Dieter 2009-01-26 11:21:11 EST
phonon upstream also said phonon-4.2.1 includes a fix for this issue too.  (except it's only tagged, with no tarball... yet).  boo.
Comment 20 Kevin Kofler 2009-01-26 11:24:52 EST
At this point, I'd say don't bother, let's go directly to 4.3.0.
Comment 21 Richard Shaw 2009-01-26 21:44:04 EST
Thanks, installing kdebase-runtime fixed it for me.
Comment 22 Fedora Update System 2009-02-04 21:27:05 EST
kdeutils-4.2.0-1.fc10, kdetoys-4.2.0-1.fc10, kdesdk-4.2.0-1.fc10, kdeplasma-addons-4.2.0-1.fc10, kdepimlibs-4.2.0-1.fc10, kdepim-4.2.0-2.fc10, kdenetwork-4.2.0-2.fc10, kdemultimedia-4.2.0-1.fc10.1, kdegraphics-4.2.0-1.fc10, kdegames-4.2.0-1.fc10, kdeedu-4.2.0-2.fc10, kdebase-runtime-4.2.0-3.fc10, kdebase-4.2.0-2.fc10, kdebindings-4.2.0-1.fc10, kdeartwork-4.2.0-1.fc10, kdeadmin-4.2.0-1.fc10.1, kdeaccessibility-4.2.0-1.fc10, soprano-2.2.1-1.fc10, strigi-0.6.3-1.fc10, akonadi-1.1.1-1.fc10, automoc-1.0-0.11.rc3.fc10, compiz-0.7.8-7.fc10, kde-settings-4.1-5.20090126svn.fc10, kde-plasma-runcommand-1.0-1.fc10, kde-plasma-quickaccess-0.7.1-7.fc10, kdebluetooth-0.3-1.fc10, kde-i18n-3.5.10-2.fc10, krazy2-2.8-7.20090127svn.fc10, phonon-4.3.0-5.fc10, kde-l10n-4.2.0-2.fc10, kdelibs-4.2.0-7.fc10, kdebase-workspace-4.2.0-4.fc10.2 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdetoys kdesdk kdeplasma-addons kdepimlibs kdepim kdenetwork kdemultimedia kdegraphics kdegames kdeedu kdebase-runtime kdebase kdebindings kdeartwork kdeadmin kdeaccessibility soprano strigi akonadi automoc compiz kde-settings kde-plasma-runcommand kde-plasma-quickaccess kdebluetooth kde-i18n krazy2 phonon kde-l10n kdelibs kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1387
Comment 23 Fedora Update System 2009-02-06 00:24:00 EST
kdeutils-4.2.0-1.fc10, kdetoys-4.2.0-1.fc10, kdesdk-4.2.0-1.fc10, kdeplasma-addons-4.2.0-1.fc10, kdepimlibs-4.2.0-1.fc10, kdepim-4.2.0-2.fc10, kdenetwork-4.2.0-2.fc10, kdemultimedia-4.2.0-1.fc10.1, kdegraphics-4.2.0-1.fc10, kdegames-4.2.0-1.fc10, kdebase-runtime-4.2.0-3.fc10, kdebase-4.2.0-2.fc10, kdebindings-4.2.0-1.fc10, kdeartwork-4.2.0-1.fc10, kdeadmin-4.2.0-1.fc10.1, kdeaccessibility-4.2.0-1.fc10, soprano-2.2.1-1.fc10, strigi-0.6.3-1.fc10, akonadi-1.1.1-1.fc10, automoc-1.0-0.11.rc3.fc10, compiz-0.7.8-7.fc10, kde-settings-4.1-5.20090126svn.fc10, kde-plasma-runcommand-1.0-1.fc10, kde-plasma-quickaccess-0.7.1-7.fc10, kdebluetooth-0.3-1.fc10, kde-i18n-3.5.10-2.fc10, krazy2-2.8-7.20090127svn.fc10, phonon-4.3.0-5.fc10, kdelibs-4.2.0-9.fc10, kdeedu-4.2.0-5.fc10, kde-l10n-4.2.0-2.fc10, kdebase-workspace-4.2.0-4.fc10.2 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdetoys kdesdk kdeplasma-addons kdepimlibs kdepim kdenetwork kdemultimedia kdegraphics kdegames kdebase-runtime kdebase kdebindings kdeartwork kdeadmin kdeaccessibility soprano strigi akonadi automoc compiz kde-settings kde-plasma-runcommand kde-plasma-quickaccess kdebluetooth kde-i18n krazy2 phonon kdelibs kdeedu kde-l10n kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1387
Comment 24 Fedora Update System 2009-02-07 17:20:51 EST
kdeutils-4.2.0-1.fc10, kdetoys-4.2.0-1.fc10, kdesdk-4.2.0-1.fc10, kdeplasma-addons-4.2.0-1.fc10, kdepimlibs-4.2.0-1.fc10, kdepim-4.2.0-2.fc10, kdenetwork-4.2.0-2.fc10, kdemultimedia-4.2.0-1.fc10.1, kdegraphics-4.2.0-1.fc10, kdegames-4.2.0-1.fc10, kdebase-runtime-4.2.0-3.fc10, kdebase-4.2.0-2.fc10, kdebindings-4.2.0-1.fc10, kdeartwork-4.2.0-1.fc10, kdeadmin-4.2.0-1.fc10.1, kdeaccessibility-4.2.0-1.fc10, soprano-2.2.1-1.fc10, strigi-0.6.3-1.fc10, akonadi-1.1.1-1.fc10, automoc-1.0-0.11.rc3.fc10, compiz-0.7.8-7.fc10, kde-plasma-runcommand-1.0-1.fc10, kde-plasma-quickaccess-0.7.1-7.fc10, kdebluetooth-0.3-1.fc10, kde-i18n-3.5.10-2.fc10, krazy2-2.8-7.20090127svn.fc10, kde-settings-4.1-6.20090206svn.fc10, phonon-4.3.0-5.fc10, kdelibs-4.2.0-9.fc10, kdeedu-4.2.0-5.fc10, kde-l10n-4.2.0-2.fc10, kdebase-workspace-4.2.0-4.fc10.2 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdetoys kdesdk kdeplasma-addons kdepimlibs kdepim kdenetwork kdemultimedia kdegraphics kdegames kdebase-runtime kdebase kdebindings kdeartwork kdeadmin kdeaccessibility soprano strigi akonadi automoc compiz kde-plasma-runcommand kde-plasma-quickaccess kdebluetooth kde-i18n krazy2 kde-settings phonon kdelibs kdeedu kde-l10n kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1387

Note You need to log in before you can comment on or make changes to this bug.