Bug 481398 - lcdproc initscripts call unknown functions
lcdproc initscripts call unknown functions
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lcdproc (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Nicolas Chauvet (kwizart)
Fedora Extras Quality Assurance
:
: 485931 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-23 21:46 EST by Eric Sandeen
Modified: 2009-05-20 19:58 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.5.2-12.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-20 19:57:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2009-01-23 21:46:03 EST
[root@mythbox ~]# /etc/init.d/LCDd start
/etc/init.d/LCDd: line 48: log_daemon_msg: command not found
/etc/init.d/LCDd: line 50: log_end_msg: command not found

These don't seem to be present in the LSB spec:

http://refspecs.linux-foundation.org/LSB_3.2.0/LSB-Core-generic/LSB-Core-generic/iniscrptfunc.html

and probably need to be replaced with something LSB-compliant?

Thanks,
-Eric
Comment 1 MartinG 2009-01-24 14:52:13 EST
Confirmed:
lcdproc-0.5.2-7.fc10.x86_64
# rpm -q lcdproc
lcdproc-0.5.2-7.fc10.x86_64
# service LCDd status
Usage: /etc/init.d/LCDd {start|stop|restart|reload|force-reload}
# service LCDd restart
/etc/init.d/LCDd: line 53: log_daemon_msg: command not found
/sbin/service: line 66:  6935 Terminated              env -i PATH="$PATH" TERM="$TERM" "${SERVICEDIR}/${SERVICE}" ${OPTIONS}
# /etc/init.d/LCDd: line 55: log_end_msg: command not found

# service lcdproc status
Usage: /etc/init.d/lcdproc {start|stop|restart|reload|force-reload}
# service lcdproc restart
/etc/init.d/lcdproc: line 53: log_daemon_msg: command not found
/sbin/service: line 66:  6966 Terminated              env -i PATH="$PATH" TERM="$TERM" "${SERVICEDIR}/${SERVICE}" ${OPTIONS}
# /etc/init.d/lcdproc: line 55: log_end_msg: command not found


It should probably use "log_success_msg" and "log_failure_msg" in some way.

Also, during boot, the init process stopped when loading LCDd (or lcdproc?), because it started a text screen showing the LCD server, this despite the fact that I had chosen a "imon" driver in /etc/LCDd.conf:
#Driver=curses
Driver=imon
Comment 2 Eric Sandeen 2009-01-24 18:43:30 EST
I've seen the boot problems too; I wonder if this may be related to the initscript parsing problems (see bug #481212 Initscript metadata parsing bug? (malformed header in lcdproc) or something else; it may need another bug filed.  :)

-Eric
Comment 3 Nicolas Chauvet (kwizart) 2009-01-26 17:45:09 EST
cvs should be open for provenpackager. On the other side I will accept someone else to be the primary maintainer of this package. I've clearly missed to spend some time on this package despite the help from Jarod.
Comment 4 Eric Sandeen 2009-01-26 17:51:40 EST
Ok, if I fix things up I'll commit them, and... consider ownership if you like.  :)
Comment 5 Jarod Wilson 2009-01-26 20:56:09 EST
Ah, I was planning to put in some work on this myself soon too. Had a minor issue w/the system my lcd was in dying on me, so I had to transplant some parts... Finally have it up and running this evening. But Eric, have at it, I suspect you're going to be using your lcd more than I use mine. :)
Comment 6 Eric Sandeen 2009-02-01 00:06:32 EST
Jarod, it seems that in v1.8 of the specfile you commented out a patch which might have actually fixed this :)

 %prep
 %setup -q
-%patch0 -p1 -b .initscripts
+#patch0 -p1 -b .initscripts
 %patch1 -p1 -b .memset_swp
+%patch2 -p1 -b .imonlcd
 chmod 644 server/drivers/timing.h

was that intentional?
Comment 7 Jarod Wilson 2009-02-02 09:14:23 EST
(In reply to comment #6)
> Jarod, it seems that in v1.8 of the specfile you commented out a patch which
> might have actually fixed this :)
> 
>  %prep
>  %setup -q
> -%patch0 -p1 -b .initscripts
> +#patch0 -p1 -b .initscripts
>  %patch1 -p1 -b .memset_swp
> +%patch2 -p1 -b .imonlcd
>  chmod 644 server/drivers/timing.h
> 
> was that intentional?

...the hell? I don't remember doing that, but it would seem I did... I'm guessing it wasn't intentional, since I can't remember doing it... :)
Comment 8 Nicolas Chauvet (kwizart) 2009-02-20 10:10:07 EST
*** Bug 485931 has been marked as a duplicate of this bug. ***
Comment 9 Nicolas Chauvet (kwizart) 2009-04-14 10:35:56 EDT
The problem is aimed to be fixed in lcdproc-0.5.2-11 (currently in rawhide only)
And will be backported in current release (F-10/F-9) in a week unless something wrong arise.
The default configuration is disabled in lcdproc initscript because ncurse isn't a relevant default driver. So initscripts will exit to 6 unless a user specific configuration file is created.
Comment 10 Fedora Update System 2009-04-26 05:33:46 EDT
lcdproc-0.5.2-11.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/lcdproc-0.5.2-11.fc9
Comment 11 Fedora Update System 2009-04-26 05:33:55 EDT
lcdproc-0.5.2-11.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/lcdproc-0.5.2-11.fc10
Comment 12 Fedora Update System 2009-04-27 17:19:54 EDT
lcdproc-0.5.2-11.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lcdproc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3903
Comment 13 Fedora Update System 2009-04-27 17:35:11 EDT
lcdproc-0.5.2-11.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update lcdproc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-4012
Comment 14 Fedora Update System 2009-05-13 12:56:45 EDT
lcdproc-0.5.2-12.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/lcdproc-0.5.2-12.fc10
Comment 15 Fedora Update System 2009-05-13 12:57:43 EDT
lcdproc-0.5.2-12.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/lcdproc-0.5.2-12.fc9
Comment 16 Fedora Update System 2009-05-15 19:30:36 EDT
lcdproc-0.5.2-12.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update lcdproc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-5012
Comment 17 Fedora Update System 2009-05-15 19:31:14 EDT
lcdproc-0.5.2-12.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lcdproc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-5016
Comment 18 Fedora Update System 2009-05-20 19:57:43 EDT
lcdproc-0.5.2-12.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2009-05-20 19:58:27 EDT
lcdproc-0.5.2-12.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.