Bug 48141 - laptop eth0 device partially broken
laptop eth0 device partially broken
Status: CLOSED DUPLICATE of bug 61705
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-07-09 15:46 EDT by Chris Runge
Modified: 2014-03-16 22:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-03-26 16:33:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Chris Runge 2001-07-09 15:46:25 EDT
Description of Problem:

Fairfax (beta 1); Dell Latitude CPx with a Xircom RealPort 10/100 + 56K
modem (non cardbus)

after the system initializes the eth0 device does not come up
service network restart does not start the device, only lo
ifup eth0 works, however

How Reproducible:


Steps to Reproduce:
1. install on Latitude CPx with Xircom RealPort 10/100 + 56K modem
2. ifconfig shows eth0 not up; service network restart doesn't start it
3. ifup eth0 works

Actual Results:

see above

Expected Results:

eth0 should be started automatically

Additional Information:
system files:

/etc/sysconfig/network :


/etc/sysconfig/network-scripts/ifcfg-eth0 :


note: I realize ONBOOT=no is set. However, the files are identical for a
7.1 install on the same laptop and the eth0 device does come up when the
machine comes up and when the network is restarted. At first I thought 7.1
was buggy, but I think I remember reading somewhere the behavior in 7.1 was
intentional; that hotplug should take care of brining the device up (or
something like that).
Comment 1 Bill Nottingham 2001-07-09 15:52:30 EDT
This is fixed with the new hotplug (2001-04-24-5) packages.
Comment 2 Chris Runge 2001-07-17 08:03:03 EDT
reopening... still an issue in beta 2

# rpm -q hotplug
Comment 3 Bill Nottingham 2001-07-17 10:47:28 EDT
aaaaaaaargh. The -6 release broke more than it fixed.

Try 2001_04_24-7. Does that work for you?

Also, which dhcp client are you using?
Comment 4 Chris Runge 2001-07-18 08:13:59 EDT
tested with hotplug-2001_04_24-7 ... still not working

I must be using dhcpcd:

$ rpm -q pump
package pump is not installed
$ rpm -q dhcpcd
I've noticed a strange insmod error during the detecting hardware phase of the
sysinit (kudzu?) -- could this be related?
Comment 5 Bill Nottingham 2001-07-18 10:49:56 EDT
No, that shouldn't be a problem.

Just to confirm, if you set it up to use static IPs, does it work OK?

Also, what initscripts do you have installed?
Comment 6 Chris Runge 2001-07-18 13:16:46 EDT

I'll check on the static IP
Comment 7 Chris Runge 2001-07-19 08:31:30 EDT
using a static IP works. so maybe the problem is a hotplug interaction with dhcpcd?
Comment 8 Trond Eivind Glomsrxd 2001-08-06 18:47:09 EDT
hotplug doesn't interact with dhcpcd - it only invokes ifup when a new interface
Comment 9 Bill Nottingham 2001-08-07 01:28:52 EDT
does it work in beta3 if the calls to check_link_down are commented out of
Comment 10 Chris Runge 2001-08-22 11:57:00 EDT
this is no longer a problem in RC 1
Comment 11 Chris Runge 2001-08-23 08:30:56 EDT
argh, reopening...

While it worked once (and so I assumed it would work again), it is having
problems again. Here's what is happening now. The interface appears to come up,
but it doesn't get an IP address from the DHCP server (note: this is on the
internal Meridian network), e.g.,

# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:10:A4:C7:47:4D
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          RX bytes:0 (0.0 b)  TX bytes:2360 (2.3 Kb)

lo        Link encap:Local Loopback
          inet addr:  Mask:
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:20 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
          RX bytes:1520 (1.4 Kb)  TX bytes:1520 (1.4 Kb)

after a couple of minutes it appears to give up and eth0 goes away:

# ifconfig
lo        Link encap:Local Loopback
          inet addr:  Mask:
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:32 errors:0 dropped:0 overruns:0 frame:0
          TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
          RX bytes:2480 (2.4 Kb)  TX bytes:2480 (2.4 Kb)

but when I try ifup eth0, it comes up:

[root@localhost root]# ifup eth0
Determining IP information for eth0... done.

it is possible that this is an internal Meridian problem, I suppose

I'm using the latest rawhide components on RC1, e.g.,

Comment 12 Bill Nottingham 2001-08-23 09:16:01 EDT
What does 'ip addr ls' show if you run it while it is bringing it 'up'?

Does using pump instead of dhcpcd work? :)
Comment 13 Chris Runge 2001-08-23 13:40:14 EDT
in some repeated testing, sometimes dhcpcd works, sometimes it doesn't

ip addr ls shows:

1: lo: <LOOPBACK,UP> mtu 16436 qdisc noqueue
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet brd scope host lo
2: eth0: <BROADCAST,NOTRAILERS,UP> mtu 1500 qdisc pfifo_fast qlen 100
    link/ether 00:10:a4:c7:47:4d brd ff:ff:ff:ff:ff:ff

I tried pump (removing dhcpcd); testing so far shows that pump works without a
Comment 14 Jay Turner 2002-03-18 21:26:34 EST
I'm not seeing this issue with the 7.2 release . . . Chris, this working with 7.2?
Comment 15 Jay Turner 2002-03-21 13:27:05 EST
OK, just a sanity check here.  If ONBOOT is 'n' . . . the interface shouldn't
start should it?  Isn't that the point of the flag anyway?
Comment 16 Trond Eivind Glomsrxd 2002-03-21 16:50:32 EST
The scripts aren't executed on boot... so far, so good. The problem is that they
are started later in the bootup process, when pcmcia is started and detects them
- hotplug like.
Comment 17 Jay Turner 2002-03-22 11:15:44 EST
OK, here's more information.  With the Skipjack tree (re0320.0) hotplug is
definitely broken.  I upgraded my 7.2 system which had 'onboot=yes' and now eth0
doesn't start on boot.  Doesn't start on network restart either.  The only way
to get eth0 up is to run 'ifup eth0'  Bill is aware of the problem, but just
wanted to document that there is indeed a problem.
Comment 18 Peter Bowen 2002-03-26 16:33:11 EST
I have this problem on my laptop (IBM TP X20) with the Lucent Wavelan card.  I
traced the problem to the is_available function.  $alias is getting set to "off"
when hotplug calls it, but it works correctly when run by hand.  Commenting out
the call to is_available fixes it on my system.
Comment 19 Bill Nottingham 2002-03-26 16:56:46 EST

*** This bug has been marked as a duplicate of 61705 ***

Note You need to log in before you can comment on or make changes to this bug.