Bug 61705 - Hotplugging Xircom card, i/f not brought up
Hotplugging Xircom card, i/f not brought up
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: grep (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Brian Brock
:
: 48141 61557 61661 61706 61730 62222 62254 62608 63596 (view as bug list)
Depends On:
Blocks: 61590 61956
  Show dependency treegraph
 
Reported: 2002-03-23 03:56 EST by Bill Crawford
Modified: 2007-04-18 12:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-26 16:56:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Extracts from /var/log/messages (1.80 KB, text/plain)
2002-03-23 04:08 EST, Bill Crawford
no flags Details
patch so grep ignores failures of closing stdout when called with '-q' (276 bytes, patch)
2002-03-26 01:12 EST, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Bill Crawford 2002-03-23 03:56:03 EST
Description of Problem:
When card is plugged in, I see an error message in /var/log/messages saying no
driver is available (not true, driver has been loaded).  Then DHCP fails to kick
in and i/f is left unconfigured i.e. with no IP address.

Version-Release number of selected component (if applicable):
[bill@marcus bill]$ rpm -q kernel-pcmcia-cs hotplug
kernel-pcmcia-cs-3.1.27-12
hotplug-2002_01_14-2

Log attached in a sec.
Comment 1 Bill Crawford 2002-03-23 04:08:29 EST
Created attachment 49824 [details]
Extracts from /var/log/messages
Comment 2 Bill Crawford 2002-03-23 04:13:20 EST
This is Dell Latitude "CPi R series" if that's any help.  I did a clean install
(over FTP using the same Xircom card).

This worked near-perfectly with 7.2, so something broke.

IIRC I saw similar warnings in the log with Enigma, but it worked anyway.

Comment 3 Alan Tam 2002-03-24 00:33:35 EST
I have the same card AND problem as yours.
The following two commands provide a temp solution.

With the card hot plugged in, type:
cardctl eject 0
cardctl insert 0

,where 0 the PCMCIA socket number (first slot is 0, second is 1).
Comment 4 Bill Crawford 2002-03-24 19:46:23 EST
I can bring up the interface by typing "ifup eth0" ... it's just annoying that
it doesn't come back when I wake the thing up again.
I've also noticed that sometimes resuming seems to hang with a blank screen if
I've unplugged the card, and the machine will wake up again if I plug the card
in.
To clarify my earlier statement: under Enigma, I still saw the warnings about a
"missing driver" but immediately afterward the DHCP would kick in and the
interface came back up.  This doesn't happen with the current install, and from
testing seems to have been broken in Raw Hide for a while.
Comment 5 Bill Crawford 2002-03-25 17:08:00 EST
Ooh look, my bug blocks bug #61590 ... what is bug #61590?  I can't read it!
Comment 6 Bill Nottingham 2002-03-25 23:51:35 EST
*** Bug 61557 has been marked as a duplicate of this bug. ***
Comment 7 Bill Nottingham 2002-03-25 23:51:42 EST
*** Bug 61661 has been marked as a duplicate of this bug. ***
Comment 8 Bill Nottingham 2002-03-25 23:52:05 EST
*** Bug 61730 has been marked as a duplicate of this bug. ***
Comment 9 Bill Nottingham 2002-03-26 00:00:01 EST
*** Bug 61706 has been marked as a duplicate of this bug. ***
Comment 10 Bill Nottingham 2002-03-26 01:11:47 EST
Whee, this is fun.

grep changed in 2.5 to try and detect failures of flushing/closing stdout, and
act accordingly. However, when it's run from network-functions via hotplug, it
has *no* stdout (its only fd is stdin). The new behavior flags this as an error,
causing the grep to fail, causing ifup to think the device isn't there.

Since '-q' is defined to not write anything to stdout, I don't think it should
care if trying to flush or close stdout failsin this case - fixed with the
attached patch.
Comment 11 Bill Nottingham 2002-03-26 01:12:38 EST
Created attachment 50404 [details]
patch so grep ignores failures of closing stdout when called with '-q'
Comment 12 Chris Ricker 2002-03-26 03:12:54 EST
Thanks, that fixes it
Comment 13 Bill Crawford 2002-03-26 09:35:55 EST
Are we supposed to see that "Status Whiteboard" comment?  Or is "Hampton" a
working title like "Blue Harvest" ?
Comment 14 Bill Crawford 2002-03-26 09:38:56 EST
Also, will this fix the init order issue?  AFAICS, this still won't allow ntpd
to start up properly (as there won't be an interface there until "pcmcia"
service starts up).
Comment 15 Bill Nottingham 2002-03-26 16:56:39 EST
*** Bug 48141 has been marked as a duplicate of this bug. ***
Comment 16 Bernhard Rosenkraenzer 2002-03-26 16:58:22 EST
Fixed in grep-2.5.1-1
Comment 17 Bill Nottingham 2002-03-28 10:23:51 EST
*** Bug 62222 has been marked as a duplicate of this bug. ***
Comment 18 Bill Nottingham 2002-04-01 15:31:46 EST
*** Bug 62254 has been marked as a duplicate of this bug. ***
Comment 19 Bill Nottingham 2002-04-03 17:59:04 EST
*** Bug 62608 has been marked as a duplicate of this bug. ***
Comment 20 Bill Nottingham 2002-04-16 01:36:24 EDT
*** Bug 63596 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.