Bug 481441 - When using a proxy, musicbrainz3 crashes when loading a CD
When using a proxy, musicbrainz3 crashes when loading a CD
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-24 17:29 EST by Joost de Heer
Modified: 2009-05-16 13:36 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.11.6-20.r6096.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-18 15:02:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joost de Heer 2009-01-24 17:29:45 EST
Description of problem:
Rhythmbox crashes with a musicbrainz error when using a proxy.

Version-Release number of selected component (if applicable):
rhythmbox-0.11.6-17.r6096.fc10.i386
libmusicbrainz3-3.0.2-1.fc10.i386
libmusicbrainz-2.1.5-7.fc10.i386
ldd of rhythmbox shows it's linked against libmusicbrainz.so.4, which is a part of libmusicbrainz-2.1.5-7.fc10.i386.

How reproducible:

Steps to Reproduce:
1. Configure a network proxy through System -> Preferences -> Internet and Network -> Network Proxy (I have 'Manual Proxy' and 'Use the same proxy for all protocols' selected)
2. Start rhythmbox and load a CD
3. Watch it crash
  
Actual results:
Rhythmbox crashes with a Musicbrainz error:

----
MusicBrainz: Found http_proxy environmnent variable "http://192.168.1.1:8080"
MusicBrainz: Connecting to http://musicbrainz.org:80
MusicBrainz: GET /ws/1/release/?type=xml&discid=kG.iIyVZRgVNf6zwVLg3FKFb0LY-
[about 2 minutes of nothing]
MusicBrainz: Result: 5 (Could not connect to proxy server: Connection timed out)
MusicBrainz: Status: 0
MusicBrainz: Response:

Segmentation fault
----

Expected results:
CD information is loaded

Additional info:
While rhythmbox is trying to get the information, the following entry is present in 'netstat -pan':
tcp        0      1 192.168.1.58:46691          192.168.1.1:*               SYN_SENT    24916/rhythmbox     

Firewall on the proxy machine logs at this moment:
Jan 24 23:16:58 router kernel: RULE 10 -- DENY IN=eth0 OUT= MAC=00:50:22:91:bc:73:00:1e:c9:83:49:61:08:00 SRC=192.168.1.58 DST=192.168.1.1 LEN=60 TOS=0x00 PREC=0x00 TTL=64 ID=13634 DF PROTO=TCP SPT=46691
 DPT=0 WINDOW=5840 RES=0x00 SYN URGP=0
Jan 24 23:17:01 router kernel: RULE 10 -- DENY IN=eth0 OUT= MAC=00:50:22:91:bc:73:00:1e:c9:83:49:61:08:00 SRC=192.168.1.58 DST=192.168.1.1 LEN=60 TOS=0x00 PREC=0x00 TTL=64 ID=13635 DF PROTO=TCP SPT=46691
 DPT=0 WINDOW=5840 RES=0x00 SYN URGP=0

So it looks like musicbrainz doesn't use the right port number for the proxy.
Comment 1 Chuck Reddan 2009-02-03 18:33:19 EST
Aside from the issue with apparently not USING the proxy, 
then it would be nice if musicbrainz didn't fail so drastically 
with the segmentation fault. When running it under GDB on my 
system, the specific statement it reports is:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb4422b90 (LWP 6079)]
0x0134f957 in mb_result_list_get_size () from /usr/lib/libmusicbrainz3.so.6
Comment 2 Bastien Nocera 2009-02-03 19:46:21 EST
Same as bug #565056 on the GNOME bz. Already fixed in later rhythmbox versions.
Comment 3 Joost de Heer 2009-02-05 14:21:43 EST
In the bugreport on the Gnome bugzilla, the incorrect proxy port isn't mentioned, as far as I can see.
Comment 4 Fedora Update System 2009-03-18 15:02:17 EDT
rhythmbox-0.11.6-20.r6096.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Joost de Heer 2009-03-21 06:21:24 EDT
Still doesn't work:

[2009-03-21 11:11:09 joost@linux ~]$ rpm -q rhythmbox
rhythmbox-0.11.6-20.r6096.fc10.i386
[2009-03-21 11:11:17 joost@linux ~]$ rhythmbox
MusicBrainz: Found http_proxy environmnent variable "http://192.168.1.1:8080"
MusicBrainz: Connecting to http://musicbrainz.org:80
MusicBrainz: GET /ws/1/release/?type=xml&discid=u3gomtmISbwJDPXl_KemQcnpxjQ-

[11:11:38 joost@linux ~]$ netstat -pan | grep rhythm
tcp        0      1 192.168.1.58:37769          192.168.1.1:*               SYN_SENT    23421/rhythmbox     

Mar 21 11:11:29 router kernel: RULE 10 -- DENY IN=eth0 OUT= MAC=00:50:22:91:bc:73:00:1e:c9:83:49:61:08:00 SRC=192.168.1.58 DST=192.168.1.1 LEN=60 TOS=0x00 PREC=0x00 TTL=64 ID=55441 DF PROTO=TCP SPT=3776
9 DPT=0 WINDOW=5840 RES=0x00 SYN URGP=0
Mar 21 11:11:32 router kernel: RULE 10 -- DENY IN=eth0 OUT= MAC=00:50:22:91:bc:73:00:1e:c9:83:49:61:08:00 SRC=192.168.1.58 DST=192.168.1.1 LEN=60 TOS=0x00 PREC=0x00 TTL=64 ID=55442 DF PROTO=TCP SPT=3776
9 DPT=0 WINDOW=5840 RES=0x00 SYN URGP=0
Mar 21 11:11:38 router kernel: RULE 10 -- DENY IN=eth0 OUT= MAC=00:50:22:91:bc:73:00:1e:c9:83:49:61:08:00 SRC=192.168.1.58 DST=192.168.1.1 LEN=60 TOS=0x00 PREC=0x00 TTL=64 ID=55443 DF PROTO=TCP SPT=3776
9 DPT=0 WINDOW=5840 RES=0x00 SYN URGP=0
Mar 21 11:11:50 router kernel: RULE 10 -- DENY IN=eth0 OUT= MAC=00:50:22:91:bc:73:00:1e:c9:83:49:61:08:00 SRC=192.168.1.58 DST=192.168.1.1 LEN=60 TOS=0x00 PREC=0x00 TTL=64 ID=55444 DF PROTO=TCP SPT=3776
9 DPT=0 WINDOW=5840 RES=0x00 SYN URGP=0
Mar 21 11:12:14 router kernel: RULE 10 -- DENY IN=eth0 OUT= MAC=00:50:22:91:bc:73:00:1e:c9:83:49:61:08:00 SRC=192.168.1.58 DST=192.168.1.1 LEN=60 TOS=0x00 PREC=0x00 TTL=64 ID=55445 DF PROTO=TCP SPT=3776
9 DPT=0 WINDOW=5840 RES=0x00 SYN URGP=0

So rhythmbox still doesn't use the proxy port.
Comment 6 John Thacker 2009-05-16 13:36:35 EDT
BTW, the released update doesn't fix similar crashes on other NULL responses, like in GNOME bz#578060.

It would be nice to at least rebuild and ship out as updates for F10 to fix crashers.

Note You need to log in before you can comment on or make changes to this bug.