Bug 482782 - anacron complains that it cannot connect to hald
anacron complains that it cannot connect to hald
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anacron (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
: 482979 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-27 22:35 EST by Michal Jaegermann
Modified: 2009-01-30 19:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-28 07:42:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2009-01-27 22:35:18 EST
Description of problem:

Freshly updated anacron complains on every startup that it failed to connect to hald and that most likely means that the later is not running (while actually it does run).  I do not have an exact wording of an error message as this happens _only_ in a startup sequence and is quickly erased by a login screen even when booting to level 3.

When trying 'service anacron start' after a login then it just shows "[OK}" without any complaints.  In log file one can find "INFO (running with inotify support)" so maybe an error shown on a screen is bogus?

Version-Release number of selected component (if applicable):
anacron-2.3-66.fc11

How reproducible:
on every startup and only then
Comment 1 Marcela Mašláňová 2009-01-28 07:42:09 EST
Thank you, fixed in rawhide.
Comment 2 Michal Jaegermann 2009-01-28 17:11:23 EST
Yeah, looking closer you are right that this is not anacron problem.  This is another instance of bug 479180; only this time with haldaemon service which is running too late.  After 'chkconfig haldaemon off; chkconfig haldaemon on'
"startup links" switch from S98haldaemon to S26haldaemon and anacron starts with S95.

I just looked at "# chkconfig: 345 26 74" line in /etc/init.d/haldaemon and got mislead by it.

How this is "fixed in rawhide"?  Just changing startup scripts does not make it so. Upgrades will bump into the same issue.
Comment 3 Marcela Mašláňová 2009-01-29 01:39:30 EST
The error message was sent to /dev/null but anyway there will be changes which probably remove anacron "init" script at all.
Comment 4 Christopher Beland 2009-01-30 19:12:24 EST
*** Bug 482979 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.