Bug 483016 - Package Review: perl-NOCpulse-Debug - Perl debug output package
Package Review: perl-NOCpulse-Debug - Perl debug output package
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jon Stanley
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F-Spacewalk
  Show dependency treegraph
 
Reported: 2009-01-29 06:00 EST by Miroslav Suchý
Modified: 2009-02-13 04:47 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 04:47:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jonstanley: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2009-01-29 06:00:35 EST
SPEC: http://miroslav.suchy.cz/fedora/perl-NOCpulse-Debug/perl-NOCpulse-Debug.spec
SRPM: http://miroslav.suchy.cz/fedora/perl-NOCpulse-Debug/perl-NOCpulse-Debug-1.23.13-1.src.rpm
Description:
NOCpulse provides application, network, systems and transaction monitoring,
coupled with a comprehensive reporting system including availability,
historical and trending reports in an easy-to-use browser interface.

This package provides an API for generating varying levels of debugging output
on various output streams.

Scratch build is without problem:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1090760

rpmlint is silent.
Comment 1 Parag AN(पराग) 2009-01-29 06:20:00 EST
As you are package submitter you should not change fedora‑review flag. Its reviewer who want to take it for review will change it to fedora-review? and when he want to approve package he then change it from fedora-review? to fedora-review+
Comment 2 Jon Stanley 2009-01-30 15:52:03 EST
I'll take care of this this evening, hopefully.
Comment 3 Jon Stanley 2009-02-01 13:21:43 EST
Sorry for the delay, I'd intended to take care of this Friday night.  But here it is.

OK - Package meets naming and packaging guidelines
OK - Spec file matches base package name.
OK - Spec has consistant macro usage.
SEE LATER - Meets Packaging Guidelines.
OK - License
OK - License field in spec matches
Not included upstream - License file included in package
OK - Spec in American English
OK - Spec is legible.
OK - Sources match upstream md5sum:
$ md5sum ../../build/SOURCES/perl-NOCpulse-Debug-1.23.13.tar.gz perl-NOCpulse-Debug-1.23.13.tar.gz 
b3d2897e6c4265561ce728568d2bce3d  ../../build/SOURCES/perl-NOCpulse-Debug-1.23.13.tar.gz
b3d2897e6c4265561ce728568d2bce3d  perl-NOCpulse-Debug-1.23.13.tar.gz

N/A - Package needs ExcludeArch
OK - BuildRequires correct
N/A - Spec handles locales/find_lang
N/A - Package is relocatable and has a reason to be.
OK - Package has %defattr and permissions on files is good.
OK - Package has a correct %clean section.
OK - Package has correct buildroot
%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
OK - Package is code or permissible content.
N/A- Doc subpackage needed/used.
No %doc files - Packages %doc files don't affect runtime.
 -- Please include the README from upstream here, and actually the full license
N/A - Headers/static libs in -devel subpackage.
N/A - Spec has needed ldconfig in post and postun
N/A - .pc files in -devel subpackage/requires pkgconfig
N/A - .so files in -devel subpackage.
N/A - -devel package Requires: %{name} = %{version}-%{release}
N/A - .la files are removed.

N/A - Package is a GUI app and has a .desktop file

OK - Package compiles and builds on at least one arch.
OK - Package has no duplicate files in %files.
FAIL - Package doesn't own any directories other packages own.
OK - Package owns all the directories it creates.
OK - No rpmlint output.
- final provides and requires are sane:
(include output of for i in *rpm; do echo $i; rpm -qp --provides $i; echo =; rpm -qp --requires $i; echo; done
manually indented after checking each line.  I also remove the rpmlib junk and anything provided by glibc.)
perl-NOCpulse-Debug-1.23.13-1.fc11.noarch.rpm
 config(perl-NOCpulse-Debug) = 1.23.13-1.fc11
 perl(NOCpulse::Debug) = 1.23
 perl(NOCpulse::Debug::Stream)  
 perl(NOCpulse::Debug::Stream::html)  
 perl(NOCpulse::Debug::Stream::html_comment)  
 perl(NOCpulse::Debug::Stream::literal)  
 perl(NOCpulse::Debug::Stream::stdout)  
 perl(NOCpulse::Debuggable)  
 perl(NOCpulse::DependencyGraph)  
 perl(NOCpulse::Log::LogManager)  
 perl(NOCpulse::Log::Logger)  
 perl(NOCpulse::Log::test::TestLogger)  
 perl-NOCpulse-Debug = 1.23.13-1.fc11
=
 config(perl-NOCpulse-Debug) = 1.23.13-1.fc11
 nocpulse-common  
 perl(:MODULE_COMPAT_5.10.0)  
 perl(Carp)  
 perl(Class::MethodMaker)  
 perl(Data::Dumper)  
 perl(IO::Handle)  
 perl(NOCpulse::Config)  
 perl(NOCpulse::Debug)  
 perl(NOCpulse::Log::LogManager)  
 perl(NOCpulse::Log::Logger)  
 

SHOULD Items:

OK, tested on x86_64 - Should build in mock.
OK - Should build on all supported archs
Didn't test - Should function as described.
No scriptlets - Should have sane scriptlets.
OK - Should have subpackages require base package with fully versioned depend.
OK - Should have dist tag
OK - Should package latest version
N/A - check for outstanding bugs on package. (For core merge reviews)

Please remove ownership of directories %{perl_vendorlib}/NOCpulse and ${_sysconfdir}/nocpulse.  These are both owned by nocpulse-common, which you Require, and two packages can't own the same directories.
Comment 4 Ralf Corsepius 2009-02-01 22:46:36 EST
(In reply to comment #3)

> Please remove ownership of directories %{perl_vendorlib}/NOCpulse and
> ${_sysconfdir}/nocpulse.  These are both owned by nocpulse-common, which you
> Require, and two packages can't own the same directories.

Jon, please make yourself familiar with the FPG. 
%{perl_vendorlib}/NOCpulse
_must_ be owned by both packages.
Comment 5 Jon Stanley 2009-02-02 15:39:32 EST
Ralf,

I respectfully disagree. Please reference https://fedoraproject.org/wiki/Packaging:Guidelines#File_and_Directory_Ownership

"Directory ownership is a little more complex than file ownership. Although the rule of thumb is the same: own all the directories you create but none of the directories of packages you depend on, there are several instances where it's desirable for multiple packages to own a directory. Examples of this are:"

<snip>

None of the examples provided appear to be applicable to this set of packages.
Comment 6 Jon Stanley 2009-02-02 15:45:58 EST
Bah, I didn't have a close look at the Perl guidelines, sorry.  It's still rather confusing, but appears to be permissible for the perl directory.

https://fedoraproject.org/wiki/Packaging/Perl#Directory_Ownership for those following along at home :)

The comment still stands about %{_sysconfdir}/nocpulse, however.
Comment 7 Miroslav Suchý 2009-02-04 11:20:17 EST
I removed ownership of ${_sysconfdir}/nocpulse
added LICENSE
did not add README since upstream (that me :) do not provide any README

Updated SPEC: http://miroslav.suchy.cz/fedora/perl-NOCpulse-Debug/perl-NOCpulse-Debug.spec
Updated SRPM: http://miroslav.suchy.cz/fedora/perl-NOCpulse-Debug/perl-NOCpulse-Debug-1.23.15-1.src.rpm
Comment 8 Jon Stanley 2009-02-11 22:58:40 EST
looks good to me now, APPROVED.  Sorry for the delay.
Comment 9 Miroslav Suchý 2009-02-12 03:34:00 EST
New Package CVS Request
=======================
Package Name: perl-NOCpulse-Debug
Short Description: Perl debug output package
Owners: msuchy
Branches: devel F-10 EL-4 EL-5
InitialCC:
Cvsextras Commits: yes
Comment 10 Kevin Fenzi 2009-02-13 01:52:50 EST
cvs done.

Note You need to log in before you can comment on or make changes to this bug.