Bug 483092 - misconfigured kdump.conf forces mkdumprd to leave incomplete builds in /tmp
Summary: misconfigured kdump.conf forces mkdumprd to leave incomplete builds in /tmp
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools
Version: 5.3
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Neil Horman
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-01-29 17:19 UTC by Subhendu Ghosh
Modified: 2016-10-04 04:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 600590 (view as bug list)
Environment:
Last Closed: 2009-09-02 09:13:59 UTC


Attachments (Terms of Use)
patch to consolidate exit cleanup in mkdumprd (8.08 KB, patch)
2009-02-12 15:02 UTC, Neil Horman
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1258 normal SHIPPED_LIVE kexec-tools bug fix and enhancement update 2009-09-01 09:09:40 UTC

Description Subhendu Ghosh 2009-01-29 17:19:45 UTC
Description of problem:
When /etc/kdump.conf contains a target that is not reachable, mkdumprd bails when it tries to create the initrd.

mkdumprd will keep getting invoked every time the system reboots or the kdump service is started/restarted since the kdump.conf timestamp is greater than the kdump-initrd. This causes /tmp to start filling up with incomplete initrd builds.

Version-Release number of selected component (if applicable):
kexec-tools-1.102pre-56.el5_3.1.i386


How reproducible:
Every time

Steps to Reproduce:
1. configure kdump
2. update /etc/kdump with an invalid target
3. after failure - note build remnants in /tmp
  
Actual results:
/tmp contains an incomplete initrd build

Expected results:
incomplete initrd builds should get cleaned out after error logging

Additional info:

Comment 1 Neil Horman 2009-02-12 15:02:12 UTC
Created attachment 331695 [details]
patch to consolidate exit cleanup in mkdumprd

hey can you give this patch a spin and confirm that it fixes your problem for me please?  Thanks!

Comment 2 Neil Horman 2009-03-23 11:10:46 UTC
ping, any update here?

Comment 3 Subhendu Ghosh 2009-04-24 19:03:25 UTC
sorry - will provide update asap

Comment 4 Neil Horman 2009-04-24 20:25:30 UTC
ok, thanks!

Comment 5 Subhendu Ghosh 2009-04-27 03:04:21 UTC
patch works.

entered bogus entry in kdump.conf
ran "service kdump restart"
no initrd.* left when using patched mkdumprd

Comment 9 errata-xmlrpc 2009-09-02 09:13:59 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1258.html


Note You need to log in before you can comment on or make changes to this bug.