Bug 600590 - misconfigured kdump.conf forces mkdumprd to leave incomplete builds in /tmp
misconfigured kdump.conf forces mkdumprd to leave incomplete builds in /tmp
Status: CLOSED DUPLICATE of bug 600577
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools (Show other bugs)
6.0
All Linux
low Severity medium
: beta
: ---
Assigned To: Cong Wang
Petr Beňas
: Regression
Depends On:
Blocks: 5to6kexecTools
  Show dependency treegraph
 
Reported: 2010-06-05 02:26 EDT by CAI Qian
Modified: 2015-01-04 17:59 EST (History)
5 users (show)

See Also:
Fixed In Version: kexec-tools-2_0_0-79_el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 483092
Environment:
Last Closed: 2010-06-29 08:32:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 Petr Beňas 2010-06-28 04:08:57 EDT
This bug should be probably closed as a duplicate of bug 600577 or vice versa. 
Currently moving to VERIFIED, but mark this one or 600577 as duplicate if you decide so.

[root@dell-pe2900-01 ~]# rpm -qa kexec-tools
kexec-tools-2.0.0-77.el6.x86_64
[root@dell-pe2900-01 ~]# cat /etc/kdump.conf
ext4 /dev/mapper/vg_dellpe290001-lv_root
core_collector makedumpfile -d 31 -c
default shell
badentry
[root@dell-pe2900-01 ~]# service kdump restart
Stopping kdump:                                            [  OK  ]
Detected change(s) the following file(s):

  /etc/kdump.conf
Rebuilding /boot/initrd-2.6.32-36.el6.x86_64kdump.img
Unknown parameter  badentry
Failed to run mkdumprd
Starting kdump:                                            [FAILED]
[root@dell-pe2900-01 ~]# ll /tmp/
total 8
-rw-------.  1 root root    4 Jun 21 08:55 disklist.OkpcC9
drwx------. 13 root root 4096 Jun 21 08:55 initrd.0WbMhN
-rw-------.  1 root root    0 Jun 21 08:55 initrd.img.decQzC

[root@dell-pe2900-01 ~]# rm -f /tmp/*
[root@dell-pe2900-01 ~]# ll /tmp/
total 0
[root@dell-pe2900-01 ~]# service kdump restart
Stopping kdump:                                            [  OK  ]
Detected change(s) the following file(s):

  /etc/kdump.conf
Rebuilding /boot/initrd-2.6.32-36.el6.x86_64kdump.img
Unknown parameter  badentry
Failed to run mkdumprd
Starting kdump:                                            [FAILED]
[root@dell-pe2900-01 ~]# ll /tmp/
total 0
[root@dell-pe2900-01 ~]# rpm -q kexec-tools
kexec-tools-2.0.0-79.el6.x86_64
Comment 5 Petr Beňas 2010-06-29 08:32:13 EDT
Since there were no comments on my proposal of closing this bug as a dup of 600577, I'm doing so.

*** This bug has been marked as a duplicate of bug 600577 ***

Note You need to log in before you can comment on or make changes to this bug.