Bug 48328 - error messages after upgrading the man package
error messages after upgrading the man package
Status: CLOSED DUPLICATE of bug 48326
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-10 05:16 EDT by Henning Schmiedehausen
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-10 05:16:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henning Schmiedehausen 2001-07-10 05:16:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.18pre17-1t i686)

Description of problem:
after upgrading to the new man-1.5i2-0.6x package, the 
cronjob from tmpwatch (/etc/cron.daily/tmpwatch) throws an
error message about missing directories

How reproducible:
Always

Steps to Reproduce:
1. Install the new man package from ftp.redhat.com
2. Wait one day
3.  Check your cron mails

error: lstat() of directory /var/cache/man/X11R6/cat? failed: No such file
or directory
error: lstat() of directory /var/catman/X11R6/cat? failed: No such file or
directory

Alternative: 

Install the man package, then call as root /etc/cron.daily/tmpwatch

	

Actual Results:  Every single of my servers in an automated upgrade process
writes
me now mails :-(

Expected Results:  No errors should be thrown if an optional directory is
missing

Additional info:

Once again you seem to have screwed up your QA. The old man
package contained the cat? directories in /var/cache/man, the new
one does not. Sheesh. Why can't you simply use the environment that your
users use
for upgrade testing but insist on using this %$"! RawHide sh*t?

Is it too much that by packing a new version of an existing program you at
least keep
all the stuff that once _was_ in that package in the new one? Or if you
remove stuff,
you check what _could_ need it? If you do such stupid mistakes in stuff
like
"man", what happens in more important packages?

RedHat quality has really taken a steep dive since a few months. You're
approaching
S**E niveau. :-(

I keep the severity on "normal", I should put it on "high". If you would
have to admin
a four digit number of servers, you would understand why.
Comment 1 Bernhard Rosenkraenzer 2001-07-10 12:11:27 EDT

*** This bug has been marked as a duplicate of 48326 ***

Note You need to log in before you can comment on or make changes to this bug.