Bug 483340 - iprdump service hangs at boot
iprdump service hangs at boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iprutils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On: 483643
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-01-30 15:46 EST by Will Woods
Modified: 2013-01-10 00:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 21:09:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will Woods 2009-01-30 15:46:50 EST
The iprdump service (which is apparently installed and enabled by default on all PPC machines) hangs at startup. This prevents any ppc machine with iprdump enabled from starting up properly.

The init script runs:
  daemon $iprdump

but /sbin/iprdump does not run as a daemon unless the --daemon flag is used. So this line should be changed to:
  daemon $iprdump --daemon
Comment 1 Roman Rakus 2009-02-16 11:33:39 EST
Which version? I have installed iprutils-2.2.13-2.fc11.ppc and there is already `daemon $iprdump --daemon'
Comment 2 Jesse Keating 2009-04-13 21:09:35 EDT
This looks like fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.