Bug 483643 - iprutils fails to build with 2.6.29 kernels (swab.h moved)
iprutils fails to build with 2.6.29 kernels (swab.h moved)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iprutils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 483340
  Show dependency treegraph
 
Reported: 2009-02-02 13:16 EST by Will Woods
Modified: 2013-01-10 00:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 21:09:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
iprutils-swab-moved.patch (408 bytes, patch)
2009-02-02 13:16 EST, Will Woods
no flags Details | Diff

  None (edit)
Description Will Woods 2009-02-02 13:16:49 EST
Created attachment 330658 [details]
iprutils-swab-moved.patch

iprutils-2.2.13 fails to build with 2.6.29 kernels - iprutils/iprlib.h has:
  #include <linux/byteorder/swab.h>
but that file has moved to linux/swab.h.

The attached patch should fix the problem.
Comment 1 Jesse Keating 2009-04-13 21:09:08 EDT
iprutils 2.2.13 has been built.

Note You need to log in before you can comment on or make changes to this bug.