Bug 483465 - grib_api : Unowned directories
grib_api : Unowned directories
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: grib_api (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On: 483469
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-01 10:52 EST by Michael Schwendt
Modified: 2009-03-17 23:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-17 23:12:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2009-02-01 10:52:31 EST
One or more directories are not included within this
package and/or its sub-packages:

=> grib_api-1.6.4-1.fc11.src.rpm
=> grib_api-devel-1.6.4-1.fc11.i386 (rawhide-development-i386)
/usr/lib/gfortran
/usr/lib/gfortran/modules

[...]

Further information:

https://fedoraproject.org/wiki/Packaging/ReviewGuidelines

MUST: A package must own all directories that it creates. If it does not
create a directory that it uses, then it should require a package which
does create that directory.

https://fedoraproject.org/wiki/Packaging/Guidelines#FileAndDirectoryOwnership
https://fedoraproject.org/wiki/Packaging/UnownedDirectories

The script to find unowned directories is not complete yet, but
still quite usable: http://mschwendt.fedorapeople.org/dircheck-remote.py
$ ./dircheck-remote.py -r rawhide -n ^grib_api
Comment 1 Patrice Dumas 2009-02-02 06:46:06 EST
grib_api-devel doesn't depend on libgfortran because it is linked statically, and the link is performed by the gfortran compiler, and the rule is not to depend explicitely on the compiler.

I don't know how to handle this one.
Comment 2 Fedora Admin XMLRPC Client 2009-03-17 20:43:12 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Jeroen van Meeuwen 2009-03-17 23:12:43 EDT
This should be fixed with the new version I just built for rawhide

Note You need to log in before you can comment on or make changes to this bug.