Bug 483469 - netcdf : Unowned directories
netcdf : Unowned directories
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: netcdf (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Ed Hill
Fedora Extras Quality Assurance
:
Depends On: 483765
Blocks: 483465 483466 483472
  Show dependency treegraph
 
Reported: 2009-02-01 10:58 EST by Michael Schwendt
Modified: 2009-10-27 14:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-27 13:55:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2009-02-01 10:58:51 EST
One or more directories are not included within this
package and/or its sub-packages:

=> netcdf-4.0.0-1.fc10.src.rpm
=> netcdf-devel-4.0.0-1.fc10.i386 (rawhide-development-i386)
/usr/lib/gfortran
/usr/lib/gfortran/modules

No other packages provides these either!
Perhaps gcc-gfortran should provide them?

[...]

Further information:

https://fedoraproject.org/wiki/Packaging/ReviewGuidelines

MUST: A package must own all directories that it creates. If it does not
create a directory that it uses, then it should require a package which
does create that directory.

https://fedoraproject.org/wiki/Packaging/Guidelines#FileAndDirectoryOwnership
https://fedoraproject.org/wiki/Packaging/UnownedDirectories

The script to find unowned directories is not complete yet, but
still quite usable: http://mschwendt.fedorapeople.org/dircheck-remote.py
$ ./dircheck-remote.py -r rawhide -n ^netcdf
Comment 1 Patrice Dumas 2009-02-01 14:38:16 EST
(In reply to comment #0)
> /usr/lib/gfortran
> /usr/lib/gfortran/modules
> 
> No other packages provides these either!
> Perhaps gcc-gfortran should provide them?

No, since they are needed at runtime. Also libgfortran could have been a the right package if it was required, but it isn't the case, at least for netcdf. I guess that libgfortran is linked statically.

So maybe filesystem is all that remains.
Comment 2 Michael Schwendt 2009-02-02 03:41:37 EST
Yeah, s/gcc-gfortran/whatever-pkg-that-provides-fortran-runtime/ ;)
Comment 3 Patrice Dumas 2009-02-02 06:47:23 EST
Hum, excerpts of
# ldd -u -r /usr/lib/libnetcdff.so.4

undefined symbol: nc_inq_atttype        (/usr/lib/libnetcdff.so.4)
undefined symbol: _gfortran_string_trim (/usr/lib/libnetcdff.so.4)

so there are linking issues here, and libgfortran is a therefore a missing dependency.




Ok, when linked dynamically, there is a dependency on libgfortran, but not when linking statically. When linking statically, the dependency is brought in by gcc-gfortran.
Comment 4 Bug Zapper 2009-06-09 07:01:21 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Orion Poplawski 2009-10-27 13:55:58 EDT
Fixed in netcdf-4.0.1-3.fc12
Comment 6 Fedora Update System 2009-10-27 14:17:27 EDT
netcdf-4.0.1-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/netcdf-4.0.1-2.fc11

Note You need to log in before you can comment on or make changes to this bug.