This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 483466 - hdf5 : Unowned directories
hdf5 : Unowned directories
Status: CLOSED DUPLICATE of bug 513985
Product: Fedora
Classification: Fedora
Component: hdf5 (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On: 483469
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-01 10:54 EST by Michael Schwendt
Modified: 2009-11-20 16:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-20 16:45:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2009-02-01 10:54:23 EST
One or more directories are not included within this
package and/or its sub-packages:

=> hdf5-1.8.1-2.fc10.src.rpm
=> hdf5-devel-1.8.1-2.fc10.i386 (rawhide-development-i386)
/usr/lib/gfortran
/usr/lib/gfortran/modules

No other packages provides these either!

[...]

Further information:

https://fedoraproject.org/wiki/Packaging/ReviewGuidelines

MUST: A package must own all directories that it creates. If it does not
create a directory that it uses, then it should require a package which
does create that directory.

https://fedoraproject.org/wiki/Packaging/Guidelines#FileAndDirectoryOwnership
https://fedoraproject.org/wiki/Packaging/UnownedDirectories

The script to find unowned directories is not complete yet, but
still quite usable: http://mschwendt.fedorapeople.org/dircheck-remote.py
$ ./dircheck-remote.py -r rawhide -n ^hdf5
Comment 1 Patrice Dumas 2009-02-02 06:38:12 EST
hdf5-devel depends on libgfortran.
Comment 2 Bug Zapper 2009-06-09 07:01:06 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Orion Poplawski 2009-11-20 16:45:36 EST

*** This bug has been marked as a duplicate of bug 513985 ***

Note You need to log in before you can comment on or make changes to this bug.