Bug 483609 - running 'reset' shrinks the terminal window
running 'reset' shrinks the terminal window
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
: 479505 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-02 11:16 EST by Nalin Dahyabhai
Modified: 2009-03-29 23:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-29 23:44:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
revert upstream patch (2.64 KB, patch)
2009-02-04 09:38 EST, Yanko Kaneti
no flags Details | Diff

  None (edit)
Description Nalin Dahyabhai 2009-02-02 11:16:02 EST
Description of problem:
When I open a terminal window, and use the 'reset' command at the command-line, the terminal windows shrinks.

Version-Release number of selected component (if applicable):
2.25.5-1.fc11

How reproducible:
Always

Steps to Reproduce:
1. Run 'resize' to check the terminal dimensions.
2. Run 'reset' to reset and clear the scrollback buffer.
3. Run 'resize' again.
  
Actual results:
The second run will show a smaller number (in my case, one column and one row are lost).

Expected results:
Terminal stays the same size.

Additional info:
In case any of this affects it, I'm using the 'miscfixed' bitmap font (10x20 pixels), and metacity as the window manager.  This doesn't happen in the 'vte' test program (from vte-devel-0.19.4-3.fc11).
Comment 1 Yanko Kaneti 2009-02-04 09:38:55 EST
Created attachment 330867 [details]
revert upstream patch

Caused by upstream 
http://svn.gnome.org/viewvc/gnome-terminal?view=revision&revision=3146

Which can be reverted with the attached patch. Sorry, no motivation to chase this further at this moment.
Comment 2 Matthias Clasen 2009-02-05 01:00:51 EST
Filed upstream: http://bugzilla.gnome.org/show_bug.cgi?id=570591
Comment 3 Matthias Clasen 2009-02-05 01:23:52 EST
*** Bug 479505 has been marked as a duplicate of this bug. ***
Comment 4 Behdad Esfahbod 2009-03-25 23:35:45 EDT
Fixed upstream.  Is in 2.26.0.  Will be tagged in f11 after beta freeze is over.

Note You need to log in before you can comment on or make changes to this bug.