Bug 483650 - ypbind binding fails after f10 -> rawhide upgrade
ypbind binding fails after f10 -> rawhide upgrade
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ypbind (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
: 484848 504840 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-02 14:18 EST by Michael J. Chudobiak
Modified: 2009-06-11 07:47 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.20.4-19.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-21 19:27:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael J. Chudobiak 2009-02-02 14:18:36 EST
After upgrading to rawhide, ypbind binds fail at ypbind service start, and remote users can no longer log in.

On the nis server, I get these logged errors:

Feb  2 14:15:28 server2 ypserv[2312]: refused connect from 192.168.0.89:56329 to procedure ypproc_match (nisavtech,shadow.byname;-1)

Downgrading to the F10 ypbind rpm fixes the problem. Has something changed in ypbind rawhide that affect nis shadow files?

My nsswitch.conf file is below.

- Mike


passwd:     files nis
shadow:     files nis
group:      files nis
hosts:      files nis dns
bootparams: nisplus [NOTFOUND=return] files
ethers:     files
netmasks:   files
networks:   files
protocols:  files
rpc:        files
services:   files
netgroup:   files nis
publickey:  nisplus
automount:  files nis
aliases:    files nisplus
Comment 1 Michael J. Chudobiak 2009-02-02 15:14:30 EST
More info - the F10 nis server has this ypserv.conf:

dns: no
files: 30
xfr_check_port: yes
*                          : *       : shadow.byname    : port
*                          : *       : passwd.adjunct.byname : port
Comment 2 Vitezslav Crhonek 2009-02-03 08:59:37 EST
Hi,

Thanks for report. Your configuration files are OK. As I investigated it right now, I bet you don't use NetworkManager. There's fix of https://bugzilla.redhat.com/show_bug.cgi?id=480096 in Rawhide and it seems breaking ypbind functionality without NM. I'll look at it...
Comment 3 Michael J. Chudobiak 2009-02-03 09:06:30 EST
As you say, I don't use NetworkManager.

I have reverted back to F10, because rawhide created more problems than it solved for me. So I can't provide much more feedback...

- Mike
Comment 4 Vitezslav Crhonek 2009-02-10 08:12:36 EST
*** Bug 484848 has been marked as a duplicate of this bug. ***
Comment 5 Vitezslav Crhonek 2009-02-10 08:14:56 EST
There's workaround - you should use "-no-dbus" option and binding works fine.
Comment 6 Michael Young 2009-02-10 08:35:17 EST
Creating the file /etc/sysconfig/ypbind containing the line
OTHER_YPBIND_OPTS="-no-dbus"
and doing a "service ypbind restart" works around the problem I was seeing with ypbind-1.20.4-13.fc11.i386 , and yes, I don't use NetworkManager.
Comment 7 Juan Quintela 2009-04-21 08:58:11 EDT
Just to confirm comment #6.  I am not using NetworkManager either, and using the "
-no-dbus" fixes my problems.
Comment 8 Michael J. Chudobiak 2009-04-21 09:38:42 EDT
So what's the expected resolution in F11? "-no-dbus" on every client?

- Mike
Comment 9 Fedora Update System 2009-05-21 07:40:51 EDT
ypbind-1.20.4-19.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ypbind-1.20.4-19.fc11
Comment 10 Fedora Update System 2009-05-21 19:27:38 EDT
ypbind-1.20.4-19.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Vitezslav Crhonek 2009-06-11 07:47:24 EDT
*** Bug 504840 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.