Bug 483829 - tcl-tclvfs package require Trf tcl extension
tcl-tclvfs package require Trf tcl extension
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: tcl-tclvfs (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-03 15:03 EST by Mikhail Kalenkov
Modified: 2009-03-20 14:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: 20080503-3.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-20 14:34:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail Kalenkov 2009-02-03 15:03:07 EST
Description of problem: tcl-tclvfs package require Trf tcl extension which is not packaged if Fedora distribution. Some quote from /usr/share/doc/tcl-tclvfs-20080503/Readme.txt
================================
The zip vfs also require 'Trf' (for its 'zip' command).
================================
Actually tar vfs also require 'Trf'

Version-Release number of selected component (if applicable):
tcl-tclvfs-20080503-1.fc10.i386

Homepage of the trf package: https://sourceforge.net/projects/tcltrf

I guess trf tcl extension should be packaged, because tcl-tclvfs is almost useless without trf.
Comment 1 Tom "spot" Callaway 2009-02-03 17:29:34 EST
Whoops. I made a package for trf, it is pending review here:

https://bugzilla.redhat.com/show_bug.cgi?id=483853
Comment 2 Fedora Update System 2009-03-18 12:57:05 EDT
tcl-tclvfs-20080503-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/tcl-tclvfs-20080503-3.fc9
Comment 3 Fedora Update System 2009-03-18 12:57:09 EDT
tcl-tclvfs-20080503-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/tcl-tclvfs-20080503-3.fc10
Comment 4 Fedora Update System 2009-03-20 14:34:10 EDT
tcl-tclvfs-20080503-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2009-03-20 14:36:44 EDT
tcl-tclvfs-20080503-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.