Bug 483931 - Crash opening MS Word docs
Crash opening MS Word docs
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-04 05:59 EST by Tim Jackson
Modified: 2009-03-16 15:39 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.0.1-15.3.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 15:39:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash log (11.00 KB, text/plain)
2009-02-04 05:59 EST, Tim Jackson
no flags Details
reproducer (28.50 KB, application/msword)
2009-02-04 10:00 EST, Caolan McNamara
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 98885 None None None Never

  None (edit)
Description Tim Jackson 2009-02-04 05:59:05 EST
Created attachment 330849 [details]
Crash log

I get a reproducible crash when opening (in Writer) two different MS Word docs that I have.

Crash log attached.

Sounds a bit like bug #482961, although not the same because:

a) it doesn't happen on all docs, just a couple of specific ones

b) removing .openoffice.org doesn't help
Comment 1 Tim Jackson 2009-02-04 06:02:55 EST
Caolan, I can't distribute the docs publicly but if access to them would help with debugging then contact me privately.
Comment 2 Tim Jackson 2009-02-04 06:06:46 EST
Package version is in crash log, but for the record it's openoffice.org-writer-3.0.1-15.2.fc10.x86_64
Comment 3 Caolan McNamara 2009-02-04 06:08:59 EST
Yeah, send me a demo one (whichever reproduced is physically smallest) and I'll have a look at it. Its definitely a specific .doc import issue rather than bug #482961
Comment 4 Caolan McNamara 2009-02-04 06:34:31 EST
reproducable
Comment 5 Caolan McNamara 2009-02-04 10:00:50 EST
Created attachment 330869 [details]
reproducer

A minimal .doc created from scratch that can reproduce this
Comment 6 Caolan McNamara 2009-02-04 10:09:46 EST
gotcha, fix checked in. Will be in >= 3.0.1-15.3
Comment 7 Fedora Update System 2009-03-10 10:13:22 EDT
openoffice.org-3.0.1-15.3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/openoffice.org-3.0.1-15.3.fc10
Comment 8 Fedora Update System 2009-03-11 13:55:32 EDT
openoffice.org-3.0.1-15.3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2568
Comment 9 Tim Jackson 2009-03-12 07:31:14 EDT
Thanks, the above update seems to fix my issue.
Comment 10 Fedora Update System 2009-03-16 15:38:25 EDT
openoffice.org-3.0.1-15.3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.