Bug 484147 - VTd: changeset 9 of 16: fix EPT cache attributes
VTd: changeset 9 of 16: fix EPT cache attributes
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: 5.4
Assigned To: Xen Maintainance List
Martin Jenner
:
Depends On: 484145
Blocks: 331741 484148
  Show dependency treegraph
 
Reported: 2009-02-04 18:45 EST by Don Dugger
Modified: 2014-07-24 23:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-05 10:22:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix EPT cache attributes (2.07 KB, patch)
2009-02-04 18:45 EST, Don Dugger
no flags Details | Diff

  None (edit)
Description Don Dugger 2009-02-04 18:45:09 EST
Created attachment 330941 [details]
fix EPT cache attributes

Description of patch:

hardcode UC for mmio of assigned devices in ept table similarly to what was
done for p2m.


Upstream Status: Accepted (in a different form)
This patch differs from upstram since it is a simplification, upstream
uses a more invasive change to allow finer grain control through the
MTRR/PAT registers, more flexible but not needed for the current use
cases for VTd.
Comment 1 Don Dugger 2009-02-05 10:22:47 EST
Process error, don't need a separate BZ per patch

Note You need to log in before you can comment on or make changes to this bug.