Bug 484148 - VTd: changeset 10 of 16: avoid redundant context mapping
VTd: changeset 10 of 16: avoid redundant context mapping
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: 5.4
Assigned To: Xen Maintainance List
Martin Jenner
:
Depends On: 484147
Blocks: 331741 484150
  Show dependency treegraph
 
Reported: 2009-02-04 18:51 EST by Don Dugger
Modified: 2014-07-24 23:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-05 10:23:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
avoid redundant context mapping (3.25 KB, patch)
2009-02-04 18:51 EST, Don Dugger
no flags Details | Diff

  None (edit)
Description Don Dugger 2009-02-04 18:51:39 EST
Created attachment 330942 [details]
avoid redundant context mapping

Description of patch:

In case DEV_TYPE_PCI in domain_context_mapping(), redundant context
mapping may occur for some devices.
                                                                                For example, the NIC is 03:00.0, and its parent bridge is: 00:1e.0.
After domain_context_mapping_one() 03:00.0 and 00:1e.0, the
'secbus' is 3 and 'bus' is 0, so will domain_context_mapping_one()
03:00.0 again -- this redundant invocation returns -EINVAL because
we have created the mapping but haven't changed pdev->domain from
Dom0 to a new domain at this time and eventually the
XEN_DOMCTL_assign_device hypercall returns a failure.
 
This patch detects this case and avoids the redundant invocation.


Upstream Status: Accepted (CS 18964)
Comment 1 Don Dugger 2009-02-05 10:23:43 EST
Process error, don't need a separate BZ per patch

Note You need to log in before you can comment on or make changes to this bug.