Bug 484183 - perl-RPM-Specfile oddity
perl-RPM-Specfile oddity
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: distribution (Show other bugs)
4.8
All Linux
medium Severity medium
: rc
: ---
Assigned To: RHEL Product and Program Management
Release Test Team
:
Depends On: 484181
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-05 04:35 EST by Marcela Mašláňová
Modified: 2016-02-08 08:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-19 10:13:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcela Mašláňová 2009-02-05 04:35:10 EST
Description of problem:
Package perl-RPM-Specfile has branches for RHEL[45] and is built for this
release as well:
 https://brewweb.devel.redhat.com/buildinfo?buildID=42399
But is not included in RHEL release (neither 5Server nor 5Client nor 4AS).
Comment 1 Miroslav Suchý 2009-02-05 04:40:20 EST
I would like to see it in RHEL since we need it for RHN Satellite. And the presence of RHEL branch and not availability in RHEL cause us problem. See BZ 476500 for mored details.
Comment 2 Jan Pazdziora 2009-02-05 05:17:34 EST
From bug 476500 which describes the same thing for RHEL 5:

-1.

We don't need this. The only place where we use the thing is satcon-make-rpm.pl
in perl-Satcon, and that can easily be rewritten by not using the RPM::Specfile
module at all.

Plus, if the package is suddenly in RHEL, and we still ship it with RHN
Satellite (the package will still be on already-released ISOs), we might be for
a version conflict.

The correct solution is to rewrite perl-Satcon not to use RPM::Specfile.

Hmmm. The script satcon-make-rpm.pl is not used anywhere in Satellite, and as a
matter of fact, it is no longer shipped in perl-Satcon (I removed it from its
.spec file).

So it's like -2.
Comment 3 Marcela Mašláňová 2009-02-19 10:13:33 EST
It was decided this package won't be needed in RHEL. This will be created in EPEL.

Note You need to log in before you can comment on or make changes to this bug.