Bug 484186 - install.pl should accept answers file with relative path
install.pl should accept answers file with relative path
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
520
All Linux
low Severity low
: ---
: ---
Assigned To: Clifford Perry
Jan Hutař
: Triaged
: 518295 (view as bug list)
Depends On:
Blocks: 462714 479461
  Show dependency treegraph
 
Reported: 2009-02-05 04:43 EST by Jan Hutař
Modified: 2014-05-09 06:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-09 06:39:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2009-02-05 04:43:07 EST
Description of problem:
When I call install.pl with '/some/file/install.pl --answer-file=answers.txt' option, it seems to me like not all of the options from it are parsed.


Version-Release number of selected component (if applicable):
Satellite-5.2.0-RHEL5-re20081028.3-x86_64-embedded-oracle.iso
Satellite-5.3.0-RHEL5-re20090203.0-x86_64-embedded-oracle.iso


How reproducible:
always


Steps to Reproduce:
1. # mount -o ro,loop /tmp/media.iso-nQ4133 /tmp/media.mnt-Nq4143
2. # /tmp/media.mnt-Nq4143/install.pl --answer-file=answers.txt --non-interactive --disconnected --run-updater


Actual results:
# /tmp/media.mnt-Nq4143/install.pl --answer-file=answers.txt --non-interactive --disconnected --run-updater --skip-db-install --skip-db-population* Starting the Red Hat Network Satellite installer.
* Performing pre-install checks.
* Pre-install checks complete.  Beginning installation.
* RHN Registration.
** Registration: Disconnected mode.  Not registering with RHN.
* Checking for uninstalled prerequisites.
* Applying updates.
* Installing RHN packages.
* Loading stage2 of the installer.
* Setting up environment and users.
** GPG: Initializing GPG and importing RHN key.
* Setting up database.
** Database: Embedded database installation SKIPPED.
** Database: Setting up database connection.
** Database: Testing database connection.
** Database: Populating database.
** Database: Skipping database population.
* Performing initial configuration.
* Activating Satellite.
No answer provided for 'Where is your satellite certificate file'


Expected results:
Installation continues


Additional info:
# cat answers.txt 
admin-email = jhutar@redhat.com
ssl-set-org = Systems Management QA Brno
ssl-set-org-unit = .
ssl-set-city = Brno
ssl-set-state = .
ssl-set-country = CZ
ssl-password = reset
satellite-cert-file = /mnt/tests/CoreOS/RHN-Satellite/Inter-Satellite-Sync/Sanity/general/redhat-internal-devel.cert
rhn-parent = satellite.rhn.webqa.redhat.com

# Only needed because of bug 480759 - should default to admin-email
ssl-set-email = jhutar@redhat.com
Comment 1 Brandon Perkins 2009-02-05 11:00:20 EST
Jan, can you please attach your answers.txt file and also give an:

ls -l /mnt/tests/CoreOS/RHN-Satellite/Inter-Satellite-Sync/Sanity/general/redhat-internal-devel.cert


Thanks.
Comment 2 Michael Mráka 2009-02-05 11:07:54 EST
In fact it seems that answer file is not read at all. :)
Comment 3 Jan Hutař 2009-02-09 10:36:45 EST
Hello,
my answers.txt:



admin-email = jhutar@redhat.com

ssl-set-org = Systems Management QA Brno
ssl-set-org-unit = .
ssl-set-city = Brno
ssl-set-state = .
ssl-set-country = CZ
ssl-password = reset

satellite-cert-file = redhat-internal-devel.cert

rhn-parent = satellite.rhn.webqa.redhat.com

# Only needed because of bug 480759 - should default to admin-email
ssl-set-email = jhutar@redhat.com



and my cert is from SVN: http://svn.rhndev.redhat.com/viewcvs/*checkout*/trunk/pm/satellite-certs/satellite-5.2/redhat-internal-devel.cert

But we think that the issue was invoked by the fac, that we was calling installer with relative path to the answers.txt:

# pwd
/some/my/path
# ls
answers.txt
# /mnt/redhat/devel/candidate-trees/Satellite-5.3.0-RHEL5-re20081223.1/x86_64/x86_64/install.pl --answer-file=answers.txt --non-interactive ...

It works with '--answer-file=/some/my/path/answers.txt'.
Comment 4 Jan Pazdziora 2009-02-12 10:15:56 EST
Reassigning to Jesus, the new Installer component owner.
Comment 6 Jan Pazdziora 2012-03-15 12:23:04 EDT
*** Bug 518295 has been marked as a duplicate of this bug. ***
Comment 7 Clifford Perry 2014-05-09 06:39:30 EDT
We have not addressed this specific bug in over 5 years years. This does not seem to have an active customer case with the bug report either. Closing out as wontfix to clear from backlog. 

Please re-open if you disagree and wish further review.

Cliff

Note You need to log in before you can comment on or make changes to this bug.