Bug 518295 - The install.pl script does not work with ~ in the path of the --answer-file option
Summary: The install.pl script does not work with ~ in the path of the --answer-file o...
Keywords:
Status: CLOSED DUPLICATE of bug 484186
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer
Version: 530
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Devan Goodwin
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2009-08-19 18:35 UTC by John Sefler
Modified: 2012-03-15 16:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-15 16:23:04 UTC


Attachments (Terms of Use)

Description John Sefler 2009-08-19 18:35:52 UTC
Description of problem:
When installing satellite with an answer file, if I reference the path to the answer file using a ~ then it seems to ignore my answer file and eventually it prompts me for the location of my cert file which was already provided in the answer file. 

Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090817.0-i386-embedded-oracle.iso


How reproducible:
always

Here is my answerfile:
[root@dhcp231-142 tmp]# cat ~/satinstall-answer-file.txt 
admin-email = jsefler@redhat.com
rhn-username = jsefler
rhn-password = redhat
rhn-http-proxy =
rhn-http-proxy-username =
rhn-http-proxy-password =
ssl-set-org = Red Hat
ssl-set-common-name = Red Hat Test
ssl-set-org-unit = RHEN
ssl-set-city = Raleigh
ssl-set-state = NC
ssl-set-country = US
ssl-password = dog8code
ssl-set-email = jsefler@redhat.com
satellite-cert-file = /root/sat530.cert
rhn-parent = satellite.rhn.webqa.redhat.com
rhn-server-name = xmlrpc.rhn.webqa.redhat.com
run-updater = yes
#skip-ssl-vhost-setup = no


Here is my install:
[root@dhcp231-142 mnt]# ./install.pl --answer-file=~/satinstall-answer-file.txt  --skip-db-install --skip-db-population
* Starting the Red Hat Network Satellite installer.
....<cut out>....
* Activating RHN Satellite.
Where is your satellite certificate file?

Actual/Expected results:
I should not be prompted for my satellite certificate.  It was supplied in the answerfile.




Additional info:
if I re-run my install with a full path to the answerfile, then all is good.
[root@dhcp231-142 mnt]# ./install.pl --answer-file=/root/satinstall-answer-file.txt  --skip-db-install --skip-db-population
* Starting the Red Hat Network Satellite installer.
* Loading answer file: /root/satinstall-answer-file.txt.
....<cut out>....

Comment 2 Jan Pazdziora 2012-03-15 16:23:04 UTC
If we get to fix bug 484186, we might consider doing this.

*** This bug has been marked as a duplicate of bug 484186 ***


Note You need to log in before you can comment on or make changes to this bug.