Bug 484217 - [PATCH] only call fedora-setup-keyboard for keyboards
Summary: [PATCH] only call fedora-setup-keyboard for keyboards
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
(Show other bugs)
Version: 10
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-02-05 14:18 UTC by Adel Gadllah
Modified: 2009-03-13 04:41 UTC (History)
4 users (show)

Fixed In Version: 1.5.3-13.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-05 22:41:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against the fdi file we ship in X (464 bytes, patch)
2009-02-05 14:18 UTC, Adel Gadllah
no flags Details | Diff

Description Adel Gadllah 2009-02-05 14:18:47 UTC
Created attachment 330987 [details]
Patch against the fdi file we ship in X

Currently we run fedora-setup-keyboard for every device that has keys (capability input.keys[1]) which results into useless calls for devices that has only one button (Power Button, Sleep Button, etc)

Changing the keyboard layout for such devices is useless, because they don't respect any layout anyway.

The attached patch fixes this by checking for the capability input.keyboard.


1; Well we are checking if input.xkb.layout exists but hal adds this for every device that has the capability input.keys in /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi 

With this patch everything should work as expected with the small benefit that we only call fedora-setup-keyboard once for most system (unless multiple keyboards are detected) which should speed up the boot process.

See https://bugzilla.redhat.com/show_bug.cgi?id=476028

Comment 1 Peter Hutterer 2009-02-05 22:41:45 UTC
Applied in xorg-x11-server-1.5.99.902-3. Thanks for the patch.

Comment 2 Fedora Update System 2009-02-24 20:45:57 UTC
xorg-x11-server-1.5.3-13.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 3 Franky Van Liedekerke 2009-02-26 21:39:21 UTC
Apparently, this fix causes more troubles than it solves, see:

https://bugzilla.redhat.com/show_bug.cgi?id=484488

Comment 4 Peter Hutterer 2009-03-13 04:41:06 UTC
Fix in F-10 has been reverted because of bug 484488 which we couldn't narrow down.
The same fix is in rawhide though where the conflicts between hal, x, gdm and gnome are resolved differently and 484488 hopefully does not have any effect.


Note You need to log in before you can comment on or make changes to this bug.