This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 484364 - block-rw-range-check.patch breaks qcow2
block-rw-range-check.patch breaks qcow2
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
: 491582 (view as bug list)
Depends On:
Blocks: F11VirtTarget 484948
  Show dependency treegraph
 
Reported: 2009-02-06 09:24 EST by Mark McLoughlin
Modified: 2009-04-09 01:41 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 484948 (view as bug list)
Environment:
Last Closed: 2009-03-16 08:52:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot showing hard drive not found message (155.74 KB, image/png)
2009-03-25 06:43 EDT, IBM Bug Proxy
no flags Details
Screenshot of a warning message we got (69.22 KB, image/png)
2009-03-25 06:43 EDT, IBM Bug Proxy
no flags Details
mx3605b cpuinfo (6.63 KB, text/plain)
2009-03-25 06:43 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Description Mark McLoughlin 2009-02-06 09:24:42 EST
If I create a new qcow2 file and try and install Fedora 8 on it, the installer never shows sda in the partitioning screen. anaconda.log shows:

  removing drive sda from disk lists; adding to skip list

Turns out this isn't a problem with kvm-83 from git, so I added some debugging to block-rw-range-check.patch:

+    if (ret)
+      printf("Failing bdrv_rd_badreq_sectors(%ld, %d) : total_sectors = %ld\n",
+             sector_num, nb_sectors, bs->total_sectors);

and I see:

  Failing bdrv_rd_badreq_sectors(192, 1) : total_sectors = 192
Comment 1 Eduardo Habkost 2009-02-10 15:43:35 EST
Reproduced here. Investigating.
Comment 2 Eduardo Habkost 2009-02-11 08:17:46 EST
Found the issue: the patch on Rawhide is using bdrv_rd_badreq_sectors() instead of bdrv_rw_badreq_sectors() on bdrv_aio_write().
Comment 3 Eduardo Habkost 2009-02-11 08:36:55 EST
Fixed on Rawhide CVS (kvm-83-4.fc11)
Comment 4 Daniel Berrange 2009-03-11 08:40:14 EDT
Reassigning: The kvm package no longer exists in rawhide/F11, since it is now part of 'qemu'.
Comment 5 Daniel Berrange 2009-03-16 08:52:49 EDT
Fix is present in new merged RPM qemu-0.10-0.9.kvm20090310git.fc11.x86_64
Comment 6 Mark McLoughlin 2009-03-25 06:38:18 EDT
*** Bug 491582 has been marked as a duplicate of this bug. ***
Comment 7 IBM Bug Proxy 2009-03-25 06:43:36 EDT
Created attachment 336611 [details]
Screenshot showing hard drive not found message
Comment 8 IBM Bug Proxy 2009-03-25 06:43:44 EDT
Created attachment 336612 [details]
Screenshot of a warning message we got
Comment 9 IBM Bug Proxy 2009-03-25 06:43:51 EDT
Created attachment 336613 [details]
mx3605b cpuinfo
Comment 10 IBM Bug Proxy 2009-04-09 01:41:48 EDT
------- Comment From pavan.naregundi@in.ibm.com 2009-04-09 01:30 EDT-------
Tested in F11beta and qemu-kvm could recognize the hard drive.

Thanks
Pavan

Note You need to log in before you can comment on or make changes to this bug.