Bug 484417 - tomboy no longer works: "Exception in Gtk# callback delegate/Out of memory"
tomboy no longer works: "Exception in Gtk# callback delegate/Out of memory"
Status: CLOSED DUPLICATE of bug 484520
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-06 12:41 EST by Tom London
Modified: 2009-02-08 13:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-08 13:42:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2009-02-06 12:41:49 EST
Description of problem:
After update to rawhide mono, tomboy stopped working.

Reverting to previous mono packages "fixes".

[tbl@tlondon ~]$ tomboy
[DEBUG]: NoteManager created with note path "/home/tbl/.tomboy".
[INFO]: Initializing Mono.Addins
[DEBUG]: AddinManager.OnAddinLoaded: Tomboy.Tomboy
[DEBUG]: 	       Name: Tomboy.Tomboy,0.10
[DEBUG]: 	Description: 
[DEBUG]: 	  Namespace: Tomboy
[DEBUG]: 	    Enabled: True
[DEBUG]: 	       File: /usr/lib64/tomboy/Tomboy.exe
[WARN]: Error initializing addin: Tomboy.NoteWikiWatcher: An exception was thrown by the type initializer for Tomboy.Contrast
[WARN]: Error initializing addin: Tomboy.NoteRenameWatcher: An exception was thrown by the type initializer for Tomboy.Contrast
[WARN]: Error initializing addin: Tomboy.NoteLinkWatcher: An exception was thrown by the type initializer for Tomboy.Contrast
[WARN]: Error initializing addin: Tomboy.NoteUrlWatcher: An exception was thrown by the type initializer for Tomboy.Contrast
[DEBUG]: AddinManager.OnAddinLoaded: Tomboy.ExportToHtmlAddin
[DEBUG]: 	       Name: Export to HTML
[DEBUG]: 	Description: Exports individual notes to HTML.
[DEBUG]: 	  Namespace: Tomboy
[DEBUG]: 	    Enabled: True
[DEBUG]: 	       File: /usr/lib64/tomboy/addins/ExportToHtml.dll
[DEBUG]: AddinManager.OnAddinLoaded: Tomboy.PrintNotesAddin
[DEBUG]: 	       Name: Printing Support
[DEBUG]: 	Description: Allows you to print a note.
[DEBUG]: 	  Namespace: Tomboy
[DEBUG]: 	    Enabled: True
[DEBUG]: 	       File: /usr/lib64/tomboy/addins/PrintNotes.dll
[DEBUG]: AddinManager.OnAddinLoaded: Tomboy.BacklinksAddin
[DEBUG]: 	       Name: Backlinks
[DEBUG]: 	Description: See which notes link to the one you're currently viewing.
[DEBUG]: 	  Namespace: Tomboy
[DEBUG]: 	    Enabled: True
[DEBUG]: 	       File: /usr/lib64/tomboy/addins/Backlinks.dll
[DEBUG]: AddinManager.OnAddinLoaded: Tomboy.FixedWidthAddin
[DEBUG]: 	       Name: Fixed Width
[DEBUG]: 	Description: Adds fixed-width font style.
[DEBUG]: 	  Namespace: Tomboy
[DEBUG]: 	    Enabled: True
[DEBUG]: 	       File: /usr/lib64/tomboy/addins/FixedWidth.dll
[WARN]: Error initializing addin: Tomboy.FixedWidth.FixedWidthNoteAddin: An exception was thrown by the type initializer for Tomboy.Contrast
[DEBUG]: AddinManager.OnAddinLoaded: Tomboy.StickyNoteImportAddin
[DEBUG]: 	       Name: Sticky Notes Importer
[DEBUG]: 	Description: Import your notes from the Sticky Notes applet.
[DEBUG]: 	  Namespace: Tomboy
[DEBUG]: 	    Enabled: True
[DEBUG]: 	       File: /usr/lib64/tomboy/addins/StickyNoteImport.dll
[DEBUG]: StickyNoteImporter: Sticky Notes XML file does not exist or is invalid!
[WARN]: Error initializing addin: Tomboy.NoteWikiWatcher: An exception was thrown by the type initializer for Tomboy.Contrast
[WARN]: Error initializing addin: Tomboy.NoteRenameWatcher: An exception was thrown by the type initializer for Tomboy.Contrast
[WARN]: Error initializing addin: Tomboy.NoteLinkWatcher: An exception was thrown by the type initializer for Tomboy.Contrast
[WARN]: Error initializing addin: Tomboy.NoteUrlWatcher: An exception was thrown by the type initializer for Tomboy.Contrast
[WARN]: Error initializing addin: Tomboy.FixedWidth.FixedWidthNoteAddin: An exception was thrown by the type initializer for Tomboy.Contrast
[WARN]: Error initializing addin: Tomboy.NoteWikiWatcher: An exception was thrown by the type initializer for Tomboy.Contrast
[WARN]: Error initializing addin: Tomboy.NoteRenameWatcher: An exception was thrown by the type initializer for Tomboy.Contrast
[WARN]: Error initializing addin: Tomboy.NoteLinkWatcher: An exception was thrown by the type initializer for Tomboy.Contrast
[WARN]: Error initializing addin: Tomboy.NoteUrlWatcher: An exception was thrown by the type initializer for Tomboy.Contrast
[WARN]: Error initializing addin: Tomboy.FixedWidth.FixedWidthNoteAddin: An exception was thrown by the type initializer for Tomboy.Contrast
[DEBUG]: AddinManager.OnAddinLoaded: Tomboy.WebDavSyncServiceAddin
[DEBUG]: 	       Name: WebDav Sync Service Add-in
[DEBUG]: 	Description: Synchronize Tomboy Notes to a WebDav URL
[DEBUG]: 	  Namespace: Tomboy
[DEBUG]: 	    Enabled: True
[DEBUG]: 	       File: /usr/lib64/tomboy/addins/WebDavSyncService.dll
[DEBUG]: AddinManager.OnAddinLoaded: Tomboy.FileSystemSyncServiceAddin
[DEBUG]: 	       Name: Local Directory Sync Service Add-in
[DEBUG]: 	Description: Synchronize Tomboy Notes to a local file system path
[DEBUG]: 	  Namespace: Tomboy
[DEBUG]: 	    Enabled: True
[DEBUG]: 	       File: /usr/lib64/tomboy/addins/FileSystemSyncService.dll
[DEBUG]: Unable to locate 'gnomesu' in your PATH
[DEBUG]: Unable to locate 'gksu' in your PATH
[DEBUG]: Unable to locate 'gksudo' in your PATH
[DEBUG]: Using '/usr/bin/kdesu' as GUI 'su' tool
[DEBUG]: Successfully found all system tools
[DEBUG]: Unable to locate 'wdfs' in your PATH
[DEBUG]: Tomboy remote control active.
[DEBUG]: EnableDisable Called: enabling... False
[DEBUG]: Creating Buffer for 'Bad Music 9'...
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.TypeInitializationException: An exception was thrown by the type initializer for Tomboy.Contrast ---> System.OutOfMemoryException: Out of memory
  at (wrapper managed-to-native) object:__icall_wrapper_mono_array_new_2 (intptr,intptr,intptr)
  at Tomboy.Contrast..cctor () [0x00000] 
  --- End of inner exception stack trace ---
  at Tomboy.NoteTag.render_foreground (ContrastPaletteColor symbol) [0x00000] 
  at Tomboy.NoteTag.set_PaletteForeground (ContrastPaletteColor value) [0x00000] 
  at Tomboy.NoteTagTable.InitCommonTags () [0x00000] 
  at Tomboy.NoteTagTable..ctor () [0x00000] 
  at Tomboy.NoteTagTable.get_Instance () [0x00000] 
  at Tomboy.Note.get_TagTable () [0x00000] 
  at Tomboy.NoteWikiWatcher.Initialize () [0x00000] 
  at Tomboy.NoteAddin.Initialize (Tomboy.Note note) [0x00000] 
  at Tomboy.AddinManager.AttachAddin (System.String ext_node_id, Tomboy.Note note, Tomboy.NoteAddin addin) [0x00000] 
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at Gtk.MenuItem.activated_cb(IntPtr menu_item)
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Gnome.Program.Run()
   at Tomboy.GnomeApplication.StartMainLoop()
   at Tomboy.Application.StartMainLoop()
   at Tomboy.Tomboy.StartTrayIcon()
   at Tomboy.Tomboy.Main(System.String[] args)
[tbl@tlondon ~]$ 

Version-Release number of selected component (if applicable):
mono-web-2.4-5.pre2.20090502svn125709.fc11.x86_64
mono-winforms-2.4-5.pre2.20090502svn125709.fc11.x86_64
mono-core-2.4-5.pre2.20090502svn125709.fc11.x86_64
tomboy-0.13.4-1.fc11.x86_64
mono-extras-2.4-5.pre2.20090502svn125709.fc11.x86_64
mono-addins-0.3.1-2.2.fc10.x86_64
mono-data-sqlite-2.4-5.pre2.20090502svn125709.fc11.x86_64
monodoc-2.4-5.pre2.20090502svn125709.fc11.x86_64
mono-data-2.4-5.pre2.20090502svn125709.fc11.x86_64


How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2009-02-08 13:42:11 EST

*** This bug has been marked as a duplicate of bug 484520 ***

Note You need to log in before you can comment on or make changes to this bug.