Bug 484520 - tomboy croaks when attempting to bring up a note
tomboy croaks when attempting to bring up a note
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tomboy (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
: 484417 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-07 14:56 EST by Jonathan Corbet
Modified: 2009-02-25 12:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-25 12:21:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Tomboy output (16.99 KB, text/plain)
2009-02-07 14:56 EST, Jonathan Corbet
no flags Details
tomboy crash opening note (6.18 KB, text/plain)
2009-02-08 13:40 EST, Tom London
no flags Details
log of tomboy dying when I try to open a note (89.16 KB, text/plain)
2009-02-10 17:18 EST, Tom "spot" Callaway
no flags Details

  None (edit)
Description Jonathan Corbet 2009-02-07 14:56:08 EST
Created attachment 331214 [details]
Tomboy output

Description of problem:

Tomboy appears to start normally, but it dies a gory death as soon as I try to actually look at one of my notes.  See attachment for the full gore experience.

Version-Release number of selected component (if applicable):
tomboy-0.13.4-1.fc11.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Start Tomboy
2. Use the menu from the panel to try to view a note
3. Where did tomboy go?
  
Actual results:

Messy crash, need to parse XML to read my notes

Expected results:

Pretty tomboy note window

Additional info:

Output attached
Comment 1 Tom London 2009-02-08 13:40:56 EST
Created attachment 331252 [details]
tomboy crash opening note

Believe this is similar to #1, with latest tomboy from koji (tomboy-0.13.4-2.fc11.x86_64).

[tbl@tlondon ~]$ rpm -qa mono\* tomboy
mono-winforms-2.4-5.pre2.20090502svn125709.fc11.x86_64
mono-data-sqlite-2.4-5.pre2.20090502svn125709.fc11.x86_64
mono-data-2.4-5.pre2.20090502svn125709.fc11.x86_64
mono-web-2.4-5.pre2.20090502svn125709.fc11.x86_64
mono-extras-2.4-5.pre2.20090502svn125709.fc11.x86_64
mono-addins-0.4-4.20081215svn105652.fc11.x86_64
tomboy-0.13.4-2.fc11.x86_64
monodoc-2.4-5.pre2.20090502svn125709.fc11.x86_64
mono-core-2.4-5.pre2.20090502svn125709.fc11.x86_64
[tbl@tlondon ~]$ 

I had previously filed this against mono, as this started with mono updates of a few days ago: https://bugzilla.redhat.com/show_bug.cgi?id=484417

I'll dup that one....
Comment 2 Tom London 2009-02-08 13:42:11 EST
*** Bug 484417 has been marked as a duplicate of this bug. ***
Comment 3 Tom "spot" Callaway 2009-02-10 17:18:00 EST
Created attachment 331488 [details]
log of tomboy dying when I try to open a note

I am having the same crash, with a slightly different backtrace.
Comment 4 Tom London 2009-02-13 10:01:25 EST
Today's update of mono packages makes this "work for me":

[root@tlondon ~]# rpm -qa mono\*
mono-web-2.4-6.pre2.20091002svn126522.fc11.x86_64
mono-data-sqlite-2.4-6.pre2.20091002svn126522.fc11.x86_64
mono-data-2.4-6.pre2.20091002svn126522.fc11.x86_64
mono-addins-0.4-4.20091002svn126354.fc11.x86_64
mono-core-2.4-6.pre2.20091002svn126522.fc11.x86_64
mono-winforms-2.4-6.pre2.20091002svn126522.fc11.x86_64
mono-extras-2.4-6.pre2.20091002svn126522.fc11.x86_64
monodoc-2.4-6.pre2.20091002svn126522.fc11.x86_64
[root@tlondon ~]#
Comment 5 Jonathan Corbet 2009-02-24 11:54:32 EST
FWIW, this problem seems to be gone with current Rawhide.  Thanks for the fix :)
Comment 6 Matthias Clasen 2009-02-25 12:21:16 EST
Ok, closing this for now then.

Note You need to log in before you can comment on or make changes to this bug.