This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 484642 - ibus doesn't enable a default engine for a new user
ibus doesn't enable a default engine for a new user
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
: i18n
: 466852 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-09 02:22 EST by A S Alam
Modified: 2013-07-02 20:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-25 01:49:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description A S Alam 2009-02-09 02:22:30 EST
Description of problem:
After install a Language (pa_IN/Punjabi), when I tried to input Punjabi (press Ctrl-Space), ibus open Setup. But not enable default language layouts.
Scim has this feature in old release. in Desktop, scim shows all Punjabi layouts, while
using Punjabi installation and a Default layout (Inscript for Punjabi) selected.

Version-Release number of selected component (if applicable):
ibus-0.1.1.20081023-3.fc11.i386

How reproducible:
evertime

Steps to Reproduce:
1. login in new language with new user
2. ctrl-space (to input  something) in any editor (or anywhere)
3.
  
Actual results:
ibus asked for setup, but not enabled layout by default for language

Expected results:
expecting default language layout enabled by default (as scim was doing)

Additional info:
Comment 1 Peng Huang 2009-02-11 03:22:44 EST
*** Bug 466852 has been marked as a duplicate of this bug. ***
Comment 2 Peng Huang 2009-02-17 06:37:23 EST
How about enable all installed engines, if user does not custom it?
Comment 3 Jens Petersen 2009-02-17 19:14:59 EST
I think that is too many - by default we install engines for all CIJK.

I would prefer initializing with just engines for the desktop locale.
Comment 4 A S Alam 2009-02-17 22:59:03 EST
I agree with Jens, If all engines are installed, then also I only like to use One language in which I used to log-in (or max 2 as user). If I need more languages, then I can add later, but default I would like to select login language only (which is same behaviour SCIM has in old fedora release).
Comment 5 Peng Huang 2009-02-24 04:25:58 EST
This feature has been implemented in upstream. And wait for next release.

Currently implementation is ibus will enable all engines belong to current locale, and those engines will be ordered by rank.
Comment 6 Peng Huang 2009-02-25 01:49:01 EST
The new release has been built

Note You need to log in before you can comment on or make changes to this bug.