Bug 484669 - RFE: update powerman to latest version (2.3.3)
RFE: update powerman to latest version (2.3.3)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: powerman (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 484666
  Show dependency treegraph
 
Reported: 2009-02-09 08:06 EST by Michal Hlavinka
Modified: 2009-04-04 17:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-04 17:11:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
init script patch (1.27 KB, patch)
2009-02-11 08:50 EST, Michal Hlavinka
no flags Details | Diff

  None (edit)
Description Michal Hlavinka 2009-02-09 08:06:22 EST
Description of problem:

https://sourceforge.net/project/showfiles.php?group_id=34170&package_id=26299&release_id=641756

missing powerman-devel ( libpowerman.h ) in 2.2.2 blocks update of nut to 2.4.0

powerman 2.3.1 is the first version that ships lib/* files
Comment 1 Jarod Wilson 2009-02-09 09:26:39 EST
Um... What? The latest powerman release I see on sf.net is 2.3, not 2.3.3, let alone 2.3.1. And it doesn't have any libpowerman.h in it. Where are these later versions coming from?
Comment 2 Steven M. Parrish 2009-02-09 09:34:13 EST
As Jarod pointed out most recent release is 2.3  there is no 2.3.3   Will work on an update to 2.3 today.
Comment 3 Michal Hlavinka 2009-02-09 10:20:13 EST
you are right, I can't see 2.3.3 tarball anywhere.

I can see 2.3.1, 2.3.2, 2.3.3 only in svn-browse. They are tagged but tarball isn't there.

note: I can see, there is also only 2.2 in the sourceforge, 2.2.1 and 2.2.2 is missing. That's odd.
Comment 4 Steven M. Parrish 2009-02-09 10:38:17 EST
Ok built 2.3 for Rawhide only at this point.  However there still is no powerman-devel package and no libpowerman.h.  My guess is 2.3.1 is the development branch of what will become 2.4
Comment 5 Michal Hlavinka 2009-02-09 10:58:43 EST
(In reply to comment #4)
> Ok built 2.3 for Rawhide only at this point.  However there still is no
> powerman-devel package and no libpowerman.h.  My guess is 2.3.1 is the
> development branch of what will become 2.4

I'll ask upstream
Comment 6 Michal Hlavinka 2009-02-09 12:41:00 EST
copy from mailing list:

Hi Michal,

I just tagged 2.3.4 and put .src.rpm and .tar.bz2 release products on SF.

Thanks,

Jim

On Mon, Feb 09, 2009 at 05:23:42PM +0100, Michal Hlavinka wrote:
> Hi,
> 
> I can see, there are only 2.2 and 2.3 tarballs on the sourceforge, but in the 
> repo, there are also tags for 2.2.1, 2.2.2, 2.3.1, 2.3.2, 2.3.3. Are these 
> versions unstable? Or is 2.3.x development for 2.4?
> 
> For nut update, I need lib/libpowerman.h and it seems it's only in 2.3.1+
> Is there any ETA for next release?
> 
> Regards,
> Michal Hlavinka
Comment 7 Steven M. Parrish 2009-02-10 10:51:25 EST
Thanks for checking with upstream.  Will work on a new release today.
Comment 8 Steven M. Parrish 2009-02-10 15:47:48 EST
Version 2.3.4 built in rawhide.  Enjoy!
Comment 9 Michal Hlavinka 2009-02-11 05:19:21 EST
please fix also rpmlint errors ( rpmlint -i powerman-2.3.4-3.fc11.x86_64.rpm )

# rpmlint x86_64/powerman-2.3.4-3.fc11.x86_64.rpm
powerman.x86_64: E: postin-without-ldconfig /usr/lib64/libpowerman.so.0.0.0
powerman.x86_64: E: library-without-ldconfig-postun /usr/lib64/libpowerman.so.0.0.0
powerman.x86_64: E: missing-mandatory-lsb-keyword Description in /etc/init.d/powerman
powerman.x86_64: W: incoherent-subsys /etc/init.d/powerman $DAEMON_NAME
powerman.x86_64: W: service-default-enabled /etc/init.d/powerman
1 packages and 0 specfiles checked; 3 errors, 2 warnings.


For building new package/big modification I recomend using make local or make srpm-scratch-build-x86_64 , it doesn't require tagging the files, so you don't need to bump release number every time build fails


Thanks for help!
Comment 10 Steven M. Parrish 2009-02-11 06:13:31 EST
Ok the 1st to errors are fixed.  the Missing LSB Keyword I will forward upstream for them to take a look at.  

Did a scratch build in Koji  http://koji.fedoraproject.org/koji/taskinfo?taskID=1119287

Check it out and let me know if all is well.
Comment 11 Michal Hlavinka 2009-02-11 08:49:37 EST
I've checked it up. Looks quite good.

> powerman.x86_64: W: service-default-enabled /etc/init.d/powerman

I can see this problem already fixed in spec file with:

> # Don't turn on by default
> %{__perl} -pi -e 's|chkconfig:.*95 5|chkconfig: - 95 5|g' \
>    $RPM_BUILD_ROOT%{_sysconfdir}/init.d/%{name}

but it fixes only
> chkconfig: runlevels startprio stopprio

now (afaik because of upstart) default init levels are specified twice:
> # Default-Start:      2 3 4 5
> # Default-Stop:       0 1 6

(I've checked that even with chkconfig: - ..., this is started by default after installation.)

so you need to change both places (see attached patch for example. You can choose if you want to modify you perl script or use patch and remove the script)

Also description: seems not missing, but again it's here only once. You need it also in the second part for upstrart (see the patch). The second description can be reported upstream. I don't think upstream will change default runlevels.

W: incoherent-subsys /etc/init.d/powerman $DAEMON_NAME
is because daemon binary is powermand (with 'd' suffix), but init script is missing that suffix. It's only warning and I don't think it so important to make another difference from upstream (you can ask upstream about this).

Thanks,
Michal
Comment 12 Michal Hlavinka 2009-02-11 08:50:39 EST
Created attachment 331562 [details]
init script patch
Comment 13 Steven M. Parrish 2009-02-11 19:27:53 EST
Michal

Decided to go with the init script patch.  The perl script was put there by the previous maintainer, personally I prefer the patch method.  And I must say thanks btw for the patch. 8-).   Down to just the one warning and will send that upstream.  Here is the koji scratch build and once you give it a look will do a real build.

http://koji.fedoraproject.org/koji/taskinfo?taskID=1120618

Sorry its taken your time to get this where it should be.  Up until now this has been a very simple package to maintain.  The addition of the new -devel subpackage has been a good learning experience.

Thanks again for the assist.  Let me know how it looks.

Steven
Comment 14 Michal Hlavinka 2009-02-12 04:50:22 EST
looks good for me, but still one thing is missing.

%{Summary} is not expanded to any text in powerman-devel's description, so you need to copy-paste-modify that text by hand

I think, it's ready to be build after you fix the description.

Note You need to log in before you can comment on or make changes to this bug.