Bug 484722 - Anaconda fails at partitioning step when running inside a kvm vm/qcow.
Anaconda fails at partitioning step when running inside a kvm vm/qcow.
Status: CLOSED DUPLICATE of bug 476433
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-09 11:53 EST by Fabian Deutsch
Modified: 2009-02-11 10:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-11 10:04:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stacktrace (15.22 KB, text/plain)
2009-02-09 12:18 EST, Fabian Deutsch
no flags Details

  None (edit)
Description Fabian Deutsch 2009-02-09 11:53:31 EST
Description of problem:
Anaconda crashes with some stacktrace (attached) when trying to install it within a kvm/qcow2 vm.

Version-Release number of selected component (if applicable):
F10 host using kvm-83-3.fc11/2.6.29-0.48-rc2.git1.fc11.i686.
VM started with the commandline given in #484721

How reproducible:
Every time.

Steps to Reproduce:
1. Start vm
2. RUn Install to Hard Drive
3. Run trough the steps with some defaults
  
Actual results:
 Stacktrace after selecting use entire drive and pressing next

Expected results:
Drive gets partitioned.

Additional info:
Comment 1 Fabian Deutsch 2009-02-09 11:54:33 EST
disk image:
qemu-img create -f qcow2 f11.sys.qcow2 20G


commandline:
sudo qemu-kvm -cdrom Fedora-11-Alpha-i686-Live/F11-Alpha-i686-Live.iso -m
1024 -usb -hda f11.sys.qcow2 -vga std  -net user -net nic -smp 2
Comment 2 Fabian Deutsch 2009-02-09 12:10:47 EST
No change when using without smp.
Comment 3 Fabian Deutsch 2009-02-09 12:18:23 EST
Created attachment 331335 [details]
Stacktrace
Comment 4 Chris Lumens 2009-02-11 10:04:57 EST

*** This bug has been marked as a duplicate of bug 476433 ***

Note You need to log in before you can comment on or make changes to this bug.