Bug 476433 - Anaconda Crashed during partition selection
Anaconda Crashed during partition selection
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 484722 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-14 12:21 EST by eric@christensenplace.us
Modified: 2009-06-15 10:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 10:36:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Crash detail (84.43 KB, text/plain)
2008-12-14 12:21 EST, eric@christensenplace.us
no flags Details

  None (edit)
Description eric@christensenplace.us 2008-12-14 12:21:08 EST
Created attachment 326880 [details]
Anaconda Crash detail

Description of problem: When trying to install F10 x86_64 from DVD anaconda crashes during the partition selection.


Version-Release number of selected component (if applicable): ?


How reproducible: Always


Steps to Reproduce:
1. Select "Remove all partitions..."
2. Select "Encrypt system"
3. Deselect sdb (only have sda selected)
4. Select "Next"
  
Actual results: Anaconda crashes


Expected results: Anaconda formats and partitions the hard drive appropriately.


Additional info: Just tried it without selecting "encrypt system".  Still crashes.
Comment 1 eric@christensenplace.us 2008-12-14 13:02:34 EST
I just tried to do the installation by selecting both sda and sdb (same configuration as above) and anaconda did not crash.  If I select just sdb, however, anaconda crashes.
Comment 2 Martin Sivák 2009-02-04 09:21:56 EST
What exactly was on those drives before the installation? Can you please describe the setup in more detail?

I tried F10 x86_64 on 64bit virtual machine with two drives. Used the exact same procedure and got the password dialog for new encrypted partition.

Also, is the media OK? Did you run a media check?
Comment 3 Chris Lumens 2009-02-11 10:04:57 EST
*** Bug 484722 has been marked as a duplicate of this bug. ***
Comment 4 Mark McLoughlin 2009-02-23 03:08:49 EST
Bug #484722 is an F11 alpha bug with an identical stack trace and describes a reproducer in more detail:

  qemu-kvm -cdrom Fedora-11-Alpha-i686-Live/F11-Alpha-i686-Live.iso -m
1024 -usb -hda f11.sys.qcow2 -vga std  -net user -net nic -smp 2

For reference, the stack trace is:

anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/partedUtils.py", line 113, in getMaxAvailPartSizeMB
    disk = part.disk
  File "/usr/lib/anaconda/autopart.py", line 1030, in processPartitioning
    request.maxResizeSize = partedUtils.getMaxAvailPartSizeMB(part)
  File "/usr/lib/anaconda/autopart.py", line 1051, in doPartitioning
    processPartitioning(diskset, requests, newParts)
  File "/usr/lib/anaconda/autopart.py", line 1214, in doClearPartAction
    doPartitioning(diskset, partitions, doRefresh = 1)
  File "/usr/lib/anaconda/autopart.py", line 1262, in doAutoPartition
    doClearPartAction(anaconda, partitions, diskset)
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1358, in nextClicked
    self.anaconda.dispatch.gotoNext()
AttributeError: 'NoneType' object has no attribute 'disk'
Comment 5 Chris Lumens 2009-02-23 09:58:28 EST
This should be fixed in rawhide, as the code involved has been adapted to work with the new pyparted.
Comment 6 Fabian Deutsch 2009-02-23 10:28:16 EST
That sounds good.
Is jigdo a way to build an ISO from the current rawhide? So I am able to test it.
Comment 7 Fabian Deutsch 2009-02-23 14:56:12 EST
I'll use the livecd-tools.
Comment 8 Fabian Deutsch 2009-02-24 11:50:23 EST
I can't use the livecd-toosl because of
https://bugzilla.redhat.com/show_bug.cgi?id=458597
Comment 9 Bug Zapper 2009-06-09 06:16:05 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 eric@christensenplace.us 2009-06-14 23:26:58 EDT
I'm no longer seeing this problem with F11.

Note You need to log in before you can comment on or make changes to this bug.