Bug 484779 - nautilus Cannot mount volume
nautilus Cannot mount volume
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ntfs-3g (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
: 484800 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-09 16:15 EST by Vinagre
Modified: 2009-07-31 11:52 EDT (History)
5 users (show)

See Also:
Fixed In Version: 2009.2.1-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-26 10:33:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vinagre 2009-02-09 16:15:37 EST
I have two disks with ntfs partitions on each, and nautilus will not mount those volumes.
output:
Cannot mount volume.
Unable to mount the volume 'Backup'.
Cannot get volume.fstype.alternative
Comment 1 Pierre Ossman 2009-02-15 07:39:20 EST
This seems related:

https://bugs.launchpad.net/ubuntu/+source/ntfs-3g/+bug/300443
Comment 2 Vinagre 2009-02-15 08:35:29 EST
I tested the fix.
su -c 'nano /usr/share/hal/fdi/policy/10osvendor/20-ntfs-config-write-policy.fdi'
to add:
<merge key="volume.fstype" type="string">ntfs-3g</merge>

It fixed the problem. :-)

------------------------------------------------------------
This is not a nautilus bug, changed to ntfs-3g.

-------------------------------------------------------------
It's wired because, now the ntfs partition are mounted but nautilus still displays this error message:
"Unable to mount location
Internal error: No mount object for mounted volume"

This should be another bug
Comment 3 Tomáš Bžatek 2009-02-16 05:35:11 EST
*** Bug 484800 has been marked as a duplicate of this bug. ***
Comment 4 Tom "spot" Callaway 2009-02-18 10:29:49 EST
Ugh. Bodhi didn't write anything here. I have updates in testing for F9 and F10 that should fix it. Please download the appropriate update and let me know if it resolves the issue.

F9: https://admin.fedoraproject.org/updates/F9/FEDORA-2009-1800
F10: https://admin.fedoraproject.org/updates/F10/FEDORA-2009-1778
Comment 5 Fedora Update System 2009-02-26 10:33:54 EST
ntfs-3g-2009.2.1-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2009-02-26 10:34:58 EST
ntfs-3g-2009.2.1-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Abhi 2009-07-31 11:52:41 EDT
I have the mentioned package installed on FC10 system. However, nautilus still produces the error:

Unable to mount location
Internal error: No mount objected for mounted volume.


If I mount the USB using the icon in left under "Places" coolumn, no such error is produced.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.