Bug 484820 - printed reports contain pages of blank lines after the report header, prior to the body.
printed reports contain pages of blank lines after the report header, prior t...
Status: CLOSED DUPLICATE of bug 480537
Product: Fedora
Classification: Fedora
Component: gtkhtml3 (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-09 22:27 EST by fred smith
Modified: 2009-02-11 09:01 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-11 05:33:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fred smith 2009-02-09 22:27:17 EST
Description of problem: 
Printed reports (in the F10 packages) emit (1) the report header followed by (2)the rest of the page being blank, followed by several more blank pages (with nothing on them at all) then finally (3) a page partially blank then the report data on that page and possibly subsequent pages of data.


Version-Release number of selected component (if applicable): 
2.2.8-2.fc10


How reproducible:
on all reports printed here (not very many, but all of them)

Steps to Reproduce:
1. create an account with data
2. choose any report
3. print it
  
Actual results:
lotsa white space

Expected results:


Additional info:
The GnuCash developers have suggested it may be an issue with gtkhtml, though they haven't seen it on (e.g.) a gentoo system using the same version of gtkhtml. THIS system has gtkhtml3-3.24.3-1.fc10, in case it matters.

another poster on the GnuCash mailing list reports that when he exports the report to html instead of printing it, it contains hundreds of <BR> just below the report header.
Comment 1 Bill Nottingham 2009-02-10 10:33:06 EST
Just as a reference point, do you have a system/version where this worked for you?
Comment 2 fred smith 2009-02-10 10:55:12 EST
Bill, I cannot give you useful data, per your question. We have been running GnuCash on FC4 ever since FC4 was current. Just built the F10 system for it and copied the data files over. Since FC4 had a MUCH older version of GC, even reports didn't work very well (or at least we didn't use them).

One user on the GnuCash list reported that when he first installed F10 he did not see the problem (the original was 2.2.7), that it began after the GnuCash 2.2.8 updates were pushed out to the fedora update repos. I cannot confirm, as I installed F10 then immediately updated everything before trying any apps.
Comment 3 Derek Atkins 2009-02-10 11:12:38 EST
Bill,

I upgraded from Fedora 7 to Fedora 10 (with updates) a few weeks ago, and it's never worked for me on F7.  At first I thought it was GnuCash Trunk having problems, but then I tested my rebuild of the 2.2 branch and that shows the same problem.

I can attempt to build a bare F10 system w/o updates and see if I can reproduce the problem there.  I could also attempt to build a bare F9 system w/o updates to test there, too... if either of these would help?   (I have a nice VM server at home that I could use for these tests).

I'll note that gnotime ALSO seems to have a similar issue on my F10 system where its reports have lots of extra blank lines.

In addition, from the GnuCash lists it sounds like people on MAC might also be seeing this, but people on Gentoo are not.  Not sure what that means, however.
Comment 4 Derek Atkins 2009-02-10 11:14:20 EST
Er, correction...  never worked for me on F10.  Obviously F7 worked fine.
Comment 5 Craig Goodyear 2009-02-10 13:06:10 EST
I am also having the same problem.  I had no problems on a 
fully updated F10 system using gnucash 2.2.7 prior to 1-7-09.  
And I think I was able to print OK after the update to 2.2.8 
on 1-7-09, but one of the updates that occurred after the 
update to gnucash 2.2.8 broke printing for me.

I installed gnucash 2.2.7 on another fully updated F10 
system about 3 days ago, and gnucash printing is broken on 
that system.
Comment 6 Derek Atkins 2009-02-10 13:18:34 EST
I just installed a F10 VM and using no updates (only the released packages) Gnucash reports work fine.  I'll try to update stuff piecemeal (as much as yum will let me) to try to track down the errant package for you...  But I might not be able to get to that until later this afternoon.

But to narrow it down it's definitely some F10 update package that causes the problem.  The F10 release packages are fine.
Comment 7 Derek Atkins 2009-02-10 13:50:39 EST
I have verified that the culprit is gtkhtml3.  When I use the gtkthml3 distributed with F10 everything is fine.  If I update gtkhtml3 to the current updates version (3.24.3-1.fc10) that's when I have the problem.  Nothing else was updated (well, I first updated gnucash to 2.2.8 without updating anything else, and it still continued to work).  Then once I updated gtkhtml (and nothing else) that's when it started failing.

Bill, note that you don't need any transactional data.  An fresh Chart of Accounts with no entries in it will still exhibit the problem.  So all you need to do is:  File -> New -> New File and walk through the druid with the defaults.  Then run Reports -> Asset & Liabilities -> Balance Sheet.
Comment 8 Milan Crha 2009-02-11 05:33:20 EST
Please update to gtkhtml-3.24.4-1.fc10, where this should be fixed.

*** This bug has been marked as a duplicate of bug 480537 ***
Comment 9 Derek Atkins 2009-02-11 09:01:49 EST
I found this package in updates-testing.  Yes, I can verify that this has actually fixed the problem.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.