Bug 484861 - kchmviewer : Conflicts with other packages
kchmviewer : Conflicts with other packages
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kchmviewer (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
: 486066 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-10 07:20 EST by Michael Schwendt
Modified: 2009-05-09 00:26 EDT (History)
7 users (show)

See Also:
Fixed In Version: 4.0-4.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-09 00:11:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the diff between the directories that seem relevant (10.32 KB, text/plain)
2009-02-10 12:42 EST, Patrice Dumas
no flags Details

  None (edit)
Description Michael Schwendt 2009-02-10 07:20:13 EST
kchmviewer-4.0-2.fc11.i386  in  rawhide-development-i386
  File conflict with: 7:kdegraphics-4.2.0-2.fc11.i386
     /usr/share/kde4/services/msits.protocol
  File conflict with: 7:kdegraphics-libs-4.2.0-2.fc11.i386
     /usr/lib/kde4/kio_msits.so
Comment 1 Patrice Dumas 2009-02-10 12:40:13 EST
I tried a diff, both codes are very similar. The one in kdegraphics looks a bit modified (one modification is the removal of author copyright from one file! but other modifcations look good).

I have no idea where this file beelongs to, I don't know exactly what this kio stuff is about.
Comment 2 Patrice Dumas 2009-02-10 12:42:33 EST
Created attachment 331440 [details]
the diff between the directories that seem relevant
Comment 3 Patrice Dumas 2009-02-18 06:11:36 EST
I contacted upstream with the diff. So far no answer.
Comment 4 Patrice Dumas 2009-02-18 06:11:47 EST
*** Bug 486066 has been marked as a duplicate of this bug. ***
Comment 5 Steven M. Parrish 2009-04-04 17:12:21 EDT
Any movement from upstream on this issue.
Comment 6 Rex Dieter 2009-04-06 09:32:24 EDT
Re: comment #1:  The conflicting bits almost certainly better belong in the core kde pkgs.  Best to omit them from here, and either leave things be, or add
Requires; kdegraphics-libs%{?_isa}

I'd be tempted to omit the Requires if possible, but one would have to test how well this works without the msits bits being present.
Comment 7 Rex Dieter 2009-04-06 09:33:50 EDT
Patrice, mind if I (or you, don't care) work on omitting the conflicting bits asap?  We can sort out the rest later (imo).
Comment 8 Rex Dieter 2009-04-06 09:40:47 EDT
OK, looks like okular snarfed the chm bits.  Another option is splitting kio-msits  into a subpkg (of kdegraphics?) and have both okular (kdegraphics) and kchmviewer depend on it.
Comment 9 Rex Dieter 2009-04-06 09:46:30 EDT
Sorry, for the bz spam, looks like libchm is shared here too, but okular links it in an essentially static way.

Another crazy option, allow okular to Obsoletes kchmviewer.

Patrice, your upstream contact (per comment #3) used the info/contact on 
http://www.kchmviewer.net/contacts.html ?  (or other?)
Comment 10 Patrice Dumas 2009-04-06 10:43:37 EDT
(In reply to comment #9)
> Sorry, for the bz spam, looks like libchm is shared here too, but okular links
> it in an essentially static way.
> 
> Another crazy option, allow okular to Obsoletes kchmviewer.

I don't think this is right, kchmviewer is much more than the kio_msits stuff... But letting out of kchmviewer the kio_msits stuff and having kchmviewer depend on the package providing is looks good to me, especially given than the codes are almost the same.

> Patrice, your upstream contact (per comment #3) used the info/contact on 
> http://www.kchmviewer.net/contacts.html ?  (or other?)  

It is. I already contacted him in the past and passed some diffs.

Anyway I am not really the maintainer anymore since I left Fedora, so the package is orphaned, so the 4 other co-maintainers (although if I recall well jpo has also left), including you can do anything with that package (I still am in EPEL and take care of kchmviewer, at least if I can manage to install koji and bodhi on my debian now that plague isn't used anymore...).
Comment 11 Fedora Admin XMLRPC Client 2009-04-27 11:14:43 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 12 Fedora Admin XMLRPC Client 2009-04-27 11:15:55 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 13 Rex Dieter 2009-04-27 11:38:14 EDT
OK, kchmviewer-4.0-4 mods made in cvs, will test here in a bit.
Comment 14 Rex Dieter 2009-04-27 12:01:11 EDT
OK, looks good, F-11 builds done, requested tagging for F-11 final,
https://fedorahosted.org/rel-eng/ticket/1650

I'll get to work on F-9, F-10 updates similarly.  Holler if anyone has questions or objections.
Comment 15 Fedora Update System 2009-04-27 12:33:30 EDT
kchmviewer-4.0-4.fc10,kdegraphics-4.2.2-5.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/kchmviewer-4.0-4.fc10,kdegraphics-4.2.2-5.fc10
Comment 16 Fedora Update System 2009-04-27 12:38:53 EDT
kchmviewer-4.0-4.fc9,kdegraphics-4.2.2-5.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kchmviewer-4.0-4.fc9,kdegraphics-4.2.2-5.fc9
Comment 17 Fedora Update System 2009-04-27 17:20:51 EDT
kchmviewer-4.0-4.fc9, kdegraphics-4.2.2-5.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update kchmviewer kdegraphics'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-3918
Comment 18 Fedora Update System 2009-04-27 17:23:48 EDT
kchmviewer-4.0-4.fc10, kdegraphics-4.2.2-5.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kchmviewer kdegraphics'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3945
Comment 19 Fedora Update System 2009-05-09 00:11:01 EDT
kchmviewer-4.0-4.fc10, kdegraphics-4.2.2-5.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2009-05-09 00:26:21 EDT
kchmviewer-4.0-4.fc9, kdegraphics-4.2.2-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.