Bug 485011 - Update request: Miro-2.0
Update request: Miro-2.0
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Miro (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 479518 480527
  Show dependency treegraph
 
Reported: 2009-02-10 23:52 EST by Michel Alexandre Salim
Modified: 2009-03-02 11:58 EST (History)
5 users (show)

See Also:
Fixed In Version: 2.0-3.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-02 11:58:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Miro spec for version 2.0 (8.71 KB, application/octet-stream)
2009-02-10 23:52 EST, Michel Alexandre Salim
no flags Details
Patch to install helper binary in libexec, not /usr/lib/miro (420 bytes, patch)
2009-02-10 23:53 EST, Michel Alexandre Salim
no flags Details | Diff
Updated patch to use system rb_libtorrent (2.06 KB, patch)
2009-02-11 01:15 EST, Alex Lancaster
no flags Details | Diff

  None (edit)
Description Michel Alexandre Salim 2009-02-10 23:52:05 EST
Created attachment 331515 [details]
Miro spec for version 2.0

Description of problem:
Miro 2.0 has just been released, and the interface looks much cleaner. I've been able to compile it without most of the patches, but as it generates some rpmlint errors, I'm not ready to check this into Rawhide just yet.

Version-Release number of selected component (if applicable):
1.2.8-5

RPMlint warnings:
Miro.x86_64: W: unstripped-binary-or-object /usr/lib64/python2.5/site-packages/miro/plat/frontends/widgets/windowcreator.so
Miro.x86_64: W: unstripped-binary-or-object /usr/lib64/python2.5/site-packages/miro/xine.so
Miro.x86_64: W: unstripped-binary-or-object /usr/lib64/python2.5/site-packages/miro/plat/frontends/widgets/pluginsdir.so
Miro.x86_64: W: unstripped-binary-or-object /usr/lib64/python2.5/site-packages/miro/sorts.so
Miro.x86_64: W: unstripped-binary-or-object /usr/lib64/python2.5/site-packages/miro/database.so
Miro.x86_64: W: unstripped-binary-or-object /usr/lib64/python2.5/site-packages/miro/fasttypes.so
Miro.x86_64: W: unstripped-binary-or-object /usr/lib64/python2.5/site-packages/miro/plat/xlibhelper.so
Miro.x86_64: W: unstripped-binary-or-object /usr/libexec/xine_extractor
Miro.x86_64: W: unstripped-binary-or-object /usr/lib64/python2.5/site-packages/miro/plat/frontends/widgets/httpobserver.so
Miro.x86_64: W: unstripped-binary-or-object /usr/lib64/python2.5/site-packages/miro/libtorrent.so
Miro.x86_64: W: unstripped-binary-or-object /usr/lib64/python2.5/site-packages/miro/plat/frontends/widgets/mozprompt.so
Miro.x86_64: W: unstripped-binary-or-object /usr/lib64/python2.5/site-packages/miro/frontends/widgets/gtk/pygtkhacks.so
Miro.x86_64: W: file-not-in-%lang /usr/share/miro/resources/testdata/locale/fr/LC_MESSAGES/miro.mo
1 packages and 0 specfiles checked; 0 errors, 13 warnings.

The last one can probably be ignored -- it's just test data. Should we remove the entire testdata directory, even? The stripping, I'm not sure why it's not done automatically.

This is tested on Fedora 10 -- still installing my Rawhide virtual machine, after downgrading the physical box back to F-10 to get a functioning Mono stack.
Comment 1 Michel Alexandre Salim 2009-02-10 23:53:32 EST
Created attachment 331516 [details]
Patch to install helper binary in libexec, not /usr/lib/miro
Comment 2 Alex Lancaster 2009-02-11 00:49:58 EST
This release allows building against system rb_libtorrent:

http://bugzilla.pculture.org/show_bug.cgi?id=10263

we should also modify the spec file to add the appropriate Requires:

+BuildRequires:  rb_libtorrent-devel rb_libtorrent-python
+Requires:      rb_libtorrent-python

and ensure that it doesn't build the bundled bindings.

The lack of stripping is odd.  Also not sure about the testdata directory if it's needed, perhaps Will can weigh in.
Comment 3 Alex Lancaster 2009-02-11 01:15:49 EST
Created attachment 331526 [details]
Updated patch to use system rb_libtorrent

I updated the patch and did a scratch koji build in rawhide:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1118843

We can also drop the boost patch as that was only needed for building libtorrent rasterbar (rb_rasterbar).
Comment 4 Alex Lancaster 2009-02-11 01:20:56 EST
Note that we may have to conditionalize the support for system rb_libtorrent for F11+ as it appears it requires at least version 0.14 but F-10 and earlier are still on 0.13.
Comment 5 will kahn-greene 2009-02-11 10:24:07 EST
Look at this bug which has a patch to allow Miro 2.0 to use system libtorrent 0.13:

http://bugzilla.pculture.org/show_bug.cgi?id=11385

I hope to apply it in 2.0.1, but it didn't make it into 2.0.

You can remove resources/testdata/.  Unit tests won't run without it, but that probably doesn't matter.

I really appreciate how fast you guys move on this.  If you need me, I'm on #miro-hackers on freenode and I'm monitoring F9 and F10 bugs in your system, too.
Comment 6 Michel Alexandre Salim 2009-02-11 19:10:16 EST
Ah. We don't currently use the unit tests, as far as I know. We should probably enable it, however, it currently fails on my machine:

======================================================================
ERROR: testRestore (miro.test.httpdownloadertest.HTTPDownloaderTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib64/python2.5/site-packages/miro/test/httpdownloadertest.py", line 138, in testRestore
    self.runEventLoop()
  File "/usr/lib64/python2.5/site-packages/miro/test/framework.py", line 135, in runEventLoop
    raise HadToStopEventLoop()
HadToStopEventLoop

----------------------------------------------------------------------
Ran 314 tests in 46.403s

FAILED (errors=1)

If the test really requires HTTP connection, I wonder if it's safe to use in the Koji build system. What are the guidelines about such cases?
Comment 7 Alex Lancaster 2009-02-12 02:56:45 EST
(In reply to comment #6)

> If the test really requires HTTP connection, I wonder if it's safe to use in
> the Koji build system. What are the guidelines about such cases?

Packages should never rely on having network connectivity during a build, as far as I know, although I'm not sure if that's codified in the packaging guidelines.  I have had to disable them in other packages (e.g. Perl packages that have test cases that want to download data from webpages).
Comment 8 Michel Alexandre Salim 2009-02-16 00:01:32 EST
Looks like the non-stripping of files is only when I'm doing local builds; Koji output is clean.

I've made a few more changes:
- use Will's patch for compiling against libtorrent 0.13
- change default download directory to ~/Videos/Miro. ~/Videos is present on the default Fedora desktop, whereas ~/Movies is a Mac/Windows folder
- Exclude testdata directory from file listing

Committing the changes to -devel, but not tagging yet. Please take a look and, if you're fine with it, tag and build? It works fine for me on F-10, so after a few days perhaps we can consider pushing an update there too.
Comment 9 Michel Alexandre Salim 2009-02-16 00:08:39 EST
Koji build for F-10:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1129253
Comment 10 Alex Lancaster 2009-02-16 02:52:03 EST
(In reply to comment #8)
> Looks like the non-stripping of files is only when I'm doing local builds; Koji
> output is clean.
> 
> I've made a few more changes:
> - use Will's patch for compiling against libtorrent 0.13
> - change default download directory to ~/Videos/Miro. ~/Videos is present on
> the default Fedora desktop, whereas ~/Movies is a Mac/Windows folder
> - Exclude testdata directory from file listing
> 
> Committing the changes to -devel, but not tagging yet. Please take a look and,
> if you're fine with it, tag and build? It works fine for me on F-10, so after a
> few days perhaps we can consider pushing an update there too.

Looks like Miro-2.0-videodir.patch wasn't committed to CVS.  Can you add and then I can test (and ultimately tag and build).  The other changes you suggest seem fine to me.
Comment 11 Michel Alexandre Salim 2009-02-16 07:41:38 EST
Patch now added.
Comment 12 Alex Lancaster 2009-02-16 08:56:25 EST
Built for rawhide:

http://koji.fedoraproject.org/koji/buildinfo?buildID=82875

We should leave this bug open and let the F-10 build close it via a bodhi update.
Comment 13 Michel Alexandre Salim 2009-02-17 10:16:02 EST
We can probably close the other two Miro bugs too: screensaver not inhibited and crash with Xine:

I'm making them block on this, so that when we push the F-10 build we don't forget to mark the update as closing those bugs too.
Comment 14 Alex Lancaster 2009-02-18 17:20:43 EST
We should also note in the bodhi notes for updates-testing that Miro 2.0 changes the configuration files in ~/.miro in a way that's backwards-incompatible with Miro 1.2.x and warn them to backup their ~/.miro directory if they want to downgrade to Miro 1.2.x after testing 2.0.
Comment 15 Alex Lancaster 2009-02-25 02:42:58 EST
I made the F-10 spec file changes and rebuilt and tested the F-10 build on my local system.  It seems to work fine.  

However, I'm still getting occasional crashes with the xine backend, but this isn't any worse than previous, so I'm going to push to updates-testing.
Comment 16 Fedora Update System 2009-02-25 03:04:26 EST
Miro-2.0-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/Miro-2.0-1.fc10
Comment 17 Fedora Update System 2009-02-25 11:26:13 EST
Miro-2.0-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2084
Comment 18 Fedora Update System 2009-02-27 05:26:45 EST
Miro-2.0-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/Miro-2.0-2.fc10
Comment 19 Fedora Update System 2009-02-27 19:22:57 EST
Miro-2.0-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2139
Comment 20 Fedora Update System 2009-02-27 22:23:09 EST
Miro-2.0-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2139
Comment 21 Fedora Update System 2009-03-02 11:57:45 EST
Miro-2.0-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.