Bug 480527 - Miro crashes after playing a video after xine-lib-1.1.16-1 update
Miro crashes after playing a video after xine-lib-1.1.16-1 update
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Miro (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
: Reopened
Depends On: 485011
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-18 05:44 EST by Jason Farrell
Modified: 2009-03-18 15:15 EDT (History)
10 users (show)

See Also:
Fixed In Version: 2.0.3-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-18 15:15:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Farrell 2009-01-18 05:44:06 EST
Description of problem:
Miro crashes after playing a video after xine-lib-1.1.16-1 update. Reproducable in a f10default VM (*without* rpmfusion's xine-lib extras).
This same bug surfaced a while back and was fixed: bug 429233

Version-Release number of selected component (if applicable):
xine-lib-1.1.16-1.fc10.x86_64

Steps to Reproduce:
1. have a default f10 installation without updates
2. install Miro and happily play multiple videos (open codecs only w/o rpmfusion)
3. "yum update xine-lib\*" to go from 1.1.15 to 1.1.16
4. restart Miro and note that it now segfaults after each video finishes playing.
Comment 1 Alex Lancaster 2009-01-18 05:54:19 EST
To the reporter: can you try reproducing this with the gstreamer backend?  (Switch in the Preferences under Playback IIRC)

Will: is this a known issue with new xine upstream?
Comment 2 Jason Farrell 2009-01-18 06:05:33 EST
Not reproducible with gstreamer - only with xine (which is the default)
Comment 3 will kahn-greene 2009-01-18 11:11:43 EST
I'm assuming this is with Miro 1.2.8.

I've not heard of this.  But if I was a betting man, I'd say it was a issue with compiling Miro against one version and running it with a different one.
Comment 4 Jason Farrell 2009-01-18 18:53:22 EST
(In reply to comment #3)
> I'm assuming this is with Miro 1.2.8.
> 
> I've not heard of this.  But if I was a betting man, I'd say it was a issue
> with compiling Miro against one version and running it with a different one.

Yes - Miro-1.2.8-1.fc10.x86_64 - and FWIW, I just now rebuilt the SRPM against xine-lib 1.1.16 and there was no change: it still crashes.
Comment 5 Alex Lancaster 2009-01-22 06:21:05 EST
I can confirm that I get a crash off sorts, the program hangs towards the end of playing a video.  I made a scratch build against xine-lib 1.1.6 as done in comment #4:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1073627

I then reinstalled this rpm and get the same kind of hang, so this would appear to be an upstream issue or problem with xine-lib 1.1.16.  Will?
Comment 6 aten 2009-01-24 12:39:25 EST
I can confirm the segfault of miro every time the video is done, no matter whether it is stopped manually or just clip is over. I've been asking about that on fedora mail list earlier https://www.redhat.com/archives/fedora-list/2009-January/msg02329.html

It does not crash with gstreamer renderer, and after I rolled back to xine* 1.1.15  miro works as before again.
Comment 7 will kahn-greene 2009-01-24 21:09:53 EST
I tried to reproduce the problem, but I can't.  I tested the Miro RPM that's in the Fedora 10 repository in my Fedora 10 vm and it works fine for me with libxine 1.1.16:

[build@localhost gtk-x11]$ rpm -q Miro xine-lib
Miro-1.2.8-1.fc10.i386
xine-lib-1.1.16-1.fc10.i386

For people who are seeing crashes, are any of you on i386 or are all the issues on x86_64?
Comment 8 Alex Lancaster 2009-01-24 21:23:03 EST
(In reply to comment #7)
> I tried to reproduce the problem, but I can't.  I tested the Miro RPM that's in
> the Fedora 10 repository in my Fedora 10 vm and it works fine for me with
> libxine 1.1.16:
> 
> [build@localhost gtk-x11]$ rpm -q Miro xine-lib
> Miro-1.2.8-1.fc10.i386
> xine-lib-1.1.16-1.fc10.i386
> 
> For people who are seeing crashes, are any of you on i386 or are all the issues
> on x86_64?

I see a "hang", not a seg fault, per se, after playing (or pausing) videos.  Basically the UI becomes unresponsive and I have to kill the process.  This is on i386.
Comment 9 will kahn-greene 2009-01-24 21:33:08 EST
Alex: I think you're the only one reporting a hang--all the other comments use the word "crash" or "segfault".  I'm not sure if that means anything, but it might indicate you've got a different issue.

Is there another frontend for xine that you could use to test playback of the videos that are hanging Miro?
Comment 10 aten 2009-01-24 22:11:19 EST
xine-lib-1.1.16-1.fc10.i386
> 
> For people who are seeing crashes, are any of you on i386 or are all the issues
> on x86_64?

I observe the crash after each video is done playing  in Fedora 9 x86_64
Comment 11 Sami Kallio 2009-01-28 23:47:58 EST
(In reply to comment #7)

> For people who are seeing crashes, are any of you on i386 or are all the issues
> on x86_64?

I'm on i386 and Miro is crashing on me after each video with error

"/usr/bin/miro: line 2:  3347 Segmentation fault      LD_LIBRARY_PATH=/usr/lib/xulrunner-1.9 miro.real "$@""

Miro-1.2.8-1.fc10.i386
xine-lib-1.1.16.1-1.fc10.i386
Comment 12 Terje Røsten 2009-02-05 14:18:17 EST
(In reply to comment #8)
> 
> I see a "hang", not a seg fault, per se, after playing (or pausing) videos. 
> Basically the UI becomes unresponsive and I have to kill the process.  This is
> on i386.

I have similar problem with flac files playing in amarok, songbird or rhythmbox
after the xine-lib update (on fc10 i386). The UI just hangs, have to kill the application from a xterm.

Tried to search for bugs upstream, however xinehq.de is down.
Comment 13 Alex Lancaster 2009-02-06 04:58:05 EST
(In reply to comment #12)

> I have similar problem with flac files playing in amarok, songbird or rhythmbox
> after the xine-lib update (on fc10 i386). The UI just hangs, have to kill the
> application from a xterm.

I can seem to play the downloads from the main xine application (it correctly terminates), so it must be something in the interaction.

> Tried to search for bugs upstream, however xinehq.de is down.

Hmm, seems that it must have been down for a while, because it was down last week.  Has upstream disappeared perhaps?
Comment 14 Terje Røsten 2009-02-11 14:02:55 EST
My problem was fixed by xine-lib 1.1.16.1-4:

 http://koji.fedoraproject.org/koji/buildinfo?buildID=82128

xine-lib 1.1.16.2 has been released and built in koji too, 
maybe that update will fix the problem?
Comment 15 Fedora Update System 2009-02-25 03:04:35 EST
Miro-2.0-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/Miro-2.0-1.fc10
Comment 16 Alex Lancaster 2009-02-25 03:10:52 EST
I submitted the update, but Miro 2.0 doesn't necessarily fix the xine crashes for me, I still get them with some files, however I added the bug to the bodhi update to make people aware of the new Miro.

Please provide feedback on the bodhi page in comment #15, however bear in mind that this update should still be pushed even if it doesn't fix all the xine problems (unless it makes them uniformly worse), as things still work with gstreamer and Miro 2.0 has fixes for other issues.
Comment 17 Jason Farrell 2009-02-25 05:19:06 EST
Thanks for packaging the 2.0 update, Alex. The GUI's been much improved.

2.0 WFM, despite the xinelib problem still crashing it after playing any video, so it's no worse than with Miro 1.2 was, but I wouldn't agree that this should be pushed to updates until this bug's been fixed, or unless the default backend is switched to gstreamer in the meantime.

For the past couple weeks since this bug reared up I haven't actually been able to use Miro as a player (though I know i could've just switched the backend from xine to gstreamer), so I've just been using it as a glorified RSS downloader, and then watching/deleting the vids externally as they showed up in the download dir.

Thanks,
Jason "zcat" Farrell
Comment 18 will kahn-greene 2009-02-25 09:32:23 EST
We're about to put out a 2.0.2 (this week for sure) which fixes a bunch of other things and some xine problems.

Uwe (Debian) pointed out that the xine-xvhack code seems to be the cause of the problems with xinelib 1.1.16.  You can compile the xine hack out by setting USE_XINE_HACK to False at the top of setup.py might help.  There's more details in setup.py.

There's a list of changes for 2.0.1 and what will become 2.0.2 in the release notes:

https://develop.participatoryculture.org/trac/democracy/wiki/2.0ReleaseNotes

Hope that helps.
Comment 19 aten 2009-02-25 10:05:42 EST
(In reply to comment #17)

> For the past couple weeks since this bug reared up I haven't actually been able
> to use Miro as a player (though I know i could've just switched the backend
> from xine to gstreamer), 


and I just rolled back to xine-lib-1.1.15-3.fc10.i386  and since then have been procrastinating with update until you guys say it's fixed. 

switching to gstreamer doesn't work for me either because after playback starts its window detaches from Miro and stays alone. Besides, gstreamer doesn't hold the aspect ratio when resizing that window. See how it looks in the end of this  thread http://getsatisfaction.com/participatoryculturefoundation/topics/miro_segfaults_after_each_video Perhaps I just don't know how to cook gstreamer.
Comment 20 Fedora Update System 2009-02-25 11:26:23 EST
Miro-2.0-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2084
Comment 21 Fedora Update System 2009-02-27 05:27:34 EST
Miro-2.0-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/Miro-2.0-2.fc10
Comment 22 Fedora Update System 2009-02-27 19:23:06 EST
Miro-2.0-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2139
Comment 23 Fedora Update System 2009-02-27 22:23:18 EST
Miro-2.0-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2139
Comment 24 Fedora Update System 2009-03-02 11:57:55 EST
Miro-2.0-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 25 Joe Bayes 2009-03-02 12:36:17 EST
I'm still having the same problem. 

Miro-2.0-3.fc10.x86_64
xine-lib-1.1.16.2-3.fc10.x86_64
xulrunner-1.9.0.6-1.fc10.x86_64

And if I downgrade to xine-lib 1.1.15-3, then I can't play videos at all -- I click the play button, and nothing happens except this gets spewed out in my terminal:

AttributeError: NullRenderer instance has no attribute 'set_widget'
Traceback (most recent call last):
  File "/usr/lib64/python2.5/site-packages/miro/frontends/widgets/gtk/weakconnect.py", line 49, in handle_callback
    return real_method(obj, *(args + self.user_args))
  File "/usr/lib64/python2.5/site-packages/miro/frontends/widgets/gtk/tableview.py", line 861, in on_button_release
    hotspot_tracker.iter)
  File "/usr/lib64/python2.5/site-packages/miro/signals.py", line 155, in emit
    if callback.invoke(self, args):
  File "/usr/lib64/python2.5/site-packages/miro/signals.py", line 89, in invoke
    return callback(obj, *(args + self.extra_args))
  File "/usr/lib64/python2.5/site-packages/miro/frontends/widgets/itemlistcontroller.py", line 263, in on_hotspot_clicked
    self._play_item_list(items)
  File "/usr/lib64/python2.5/site-packages/miro/frontends/widgets/itemlistcontroller.py", line 165, in _play_item_list
    app.playback_manager.start_with_items(playable, presentation_mode)
  File "/usr/lib64/python2.5/site-packages/miro/frontends/widgets/playback.py", line 146, in start_with_items
    self.video_display = VideoDisplay()
  File "/usr/lib64/python2.5/site-packages/miro/frontends/widgets/displays.py", line 412, in __init__
    self.renderer = widgetset.VideoRenderer()
  File "/usr/lib64/python2.5/site-packages/miro/frontends/widgets/gtk/video.py", line 407, in __init__
    self._video_widget = VideoWidget(self.renderer)
  File "/usr/lib64/python2.5/site-packages/miro/frontends/widgets/gtk/video.py", line 217, in __init__
    renderer.set_widget(self._widget)
AttributeError: NullRenderer instance has no attribute 'set_widget'
Comment 26 Michel Alexandre Salim 2009-03-02 13:51:45 EST
(In reply to comment #25)
> I'm still having the same problem. 
> 
> Miro-2.0-3.fc10.x86_64
> xine-lib-1.1.16.2-3.fc10.x86_64
> xulrunner-1.9.0.6-1.fc10.x86_64

Does the gstreamer backend work for you?
Comment 27 Joe Bayes 2009-03-02 14:26:20 EST
gstreamer works for video, but not audio. Which is an improvement; up until now, gstreamer has given me a "I can't play this format" error. 

Has anybody who had the xine problem before gotten xine working with 2.0-3?
Comment 28 Michel Alexandre Salim 2009-03-02 14:36:56 EST
We should probably try and get this resolved once and for all.

- which feed are you using
- rpm -qa gstreamer\*

With the correct third-party-repo (rpmfusion) enabled, gstreamer should decode both audio and video just fine. Without this repo, xine would not work properly either as the necessary codecs are in xine-lib-extras-freeworld. Unless you use another repo that has the xine-lib plugins but not gstreamer.

(Which might be a useful test: if you did use a different xine-lib-* RPM, could you switch to rpmfusion's and see if that works?)
Comment 29 Joe Bayes 2009-03-02 17:10:38 EST
$ rpm -qa gstreamer\*
gstreamer-python-0.10.12-1.fc10.x86_64
gstreamer-plugins-ugly-0.10.10-2.fc10.x86_64
gstreamer-plugins-good-0.10.13-1.fc10.x86_64
gstreamer-ffmpeg-0.10.5-1.fc10.x86_64
gstreamer-plugins-flumpegdemux-0.10.15-4.fc10.x86_64
gstreamer-tools-0.10.21-2.fc10.x86_64
gstreamer-plugins-base-0.10.21-2.fc10.x86_64
gstreamer-0.10.21-2.fc10.x86_64
$ rpm -qa xine\*
xinetd-2.3.14-21.fc10.x86_64
xine-lib-1.1.16.2-1.fc10.x86_64
xine-0.99.5-5.fc10.x86_64
xine-lib-extras-freeworld-1.1.16.2-1.fc10.x86_64
xine-lib-pulseaudio-1.1.16.2-1.fc10.x86_64
spoo:~$ rpm -q xulrunner
xulrunner-1.9.0.6-1.fc10.x86_64
$ 

xine is from rpmfusion. 

One of many feeds that isn't working for me (but was working a month ago) is 
http://feeds.feedburner.com/crankmychain

Specifically, with this feed, using gstreamer, if I click play on the "Whatever happened to Critical Mass in Portland" (which is a mov), I get a black screen -- no audio, no video. If I click on "Rep. Boehner Thinks American Families Hate Bike Paths", which is an mp4, I get video but no audio. 

If I use xine instead, the videos play fine, but segfault miro when I stop them.
Comment 30 Alex Lancaster 2009-03-02 18:12:40 EST
The latest release wasn't necessarily supposed to fix the xine issue, but I added it to notify users that it *might*.  Unfortunately there isn't anyway to selectively ask bodhi to close some bugs and not others.  Anyway I'm re-opening it now.

Regarding the problem itself, comment #18 indicates that they are working on this upstream and that 2.0.2 may fix this.  Also we should put out another testing update and try the following:

> Uwe (Debian) pointed out that the xine-xvhack code seems to be the cause of the
> problems with xinelib 1.1.16.  You can compile the xine hack out by setting
> USE_XINE_HACK to False at the top of setup.py might help.  There's more details
> in setup.py.
Comment 31 Michel Alexandre Salim 2009-03-02 21:11:54 EST
Try installing gstreamer-plugins-bad ? And yes, we should try turning off USE_XINE_HACK too.
Comment 32 Joe Bayes 2009-03-07 00:24:57 EST
There we go. With gstreamer-plugins-bad, gstreamer now works.
Comment 33 Philip Rhoades 2009-03-09 04:57:09 EDT
Confirmed with Fedora 10 and Miro 2.0.4 as well - thanks!
Comment 34 Alex Lancaster 2009-03-09 05:13:11 EDT
(In reply to comment #33)
> Confirmed with Fedora 10 and Miro 2.0.4 as well - thanks!  

Miro 2.0.4?  Do you mean Miro 2.0.2 which was released on the 7 March?

Also you are confirming that gstreamer playback works, not that xine playback works, right?
Comment 35 Philip Rhoades 2009-03-09 05:24:58 EDT
(In reply to comment #34)
> (In reply to comment #33)
> > Confirmed with Fedora 10 and Miro 2.0.4 as well - thanks!  
> 
> Miro 2.0.4?  Do you mean Miro 2.0.2 which was released on the 7 March?

Sorry, I meant Miro-2.0-4.fc10.i386 - just installed now.

> Also you are confirming that gstreamer playback works, not that xine playback
> works, right?

Correct - I had tried gstreamer with 2.0-2 and 2.0-3 but it didn't work until I saw the above comment and installed gstreamer-plugins-bad . . xine playback still crashes on video ending/stopping.

Phil.
Comment 36 Alex Lancaster 2009-03-09 06:29:55 EDT
I just pushed 2.0.2 to testing:

http://admin.fedoraproject.org/updates/Miro-2.0.2-1.fc10

although in my testing, this didn't quite fix the xine issues (still get segfaults) and therefore I didn't mark this bug as being fixed by that update.  Although I did get through some videos without crashing if they weren't the last in the list.  I think this is still yet to be properly fixed upstream see:

http://bugzilla.pculture.org/show_bug.cgi?id=11435
Comment 37 Alex Lancaster 2009-03-16 06:12:29 EDT
New pending build:

http://admin.fedoraproject.org/updates/Miro-2.0.3-1.fc10

about to go to testing.  This disables the xine hack which fixes things for me.
Comment 38 Jason Farrell 2009-03-16 11:49:47 EDT
Thanks alex - fixes the crashing with xine-lib-1.1.16 here too. and so perhaps the default backend can also be changed back to xine from gstreamer for the final release.
Comment 39 Fedora Update System 2009-03-16 15:52:11 EDT
Miro-2.0.3-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2766
Comment 40 Alex Lancaster 2009-03-16 21:05:06 EDT
(In reply to comment #38)
> Thanks alex - fixes the crashing with xine-lib-1.1.16 here too. and so perhaps
> the default backend can also be changed back to xine from gstreamer for the
> final release.  

gstreamer is default upstream now too, and now Miro installs the default gstreamer bindings properly (bug #489134) so we'll be sticking with that as the default.  Users can always switch between to xine playback if they prefer.
Comment 41 Fedora Update System 2009-03-18 15:15:16 EDT
Miro-2.0.3-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.