This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 485263 - gnome-system-log crashes
gnome-system-log crashes
Status: CLOSED DUPLICATE of bug 484770
Product: Fedora
Classification: Fedora
Component: gnome-utils (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 12:24 EST by Kent Baxley
Modified: 2009-02-13 01:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 01:49:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
coredump of gnome-system-log (2.36 MB, application/octet-stream)
2009-02-12 12:24 EST, Kent Baxley
no flags Details

  None (edit)
Description Kent Baxley 2009-02-12 12:24:55 EST
Created attachment 331718 [details]
coredump of gnome-system-log

Description of problem:

gnome-system-log crashes


Version-Release number of selected component (if applicable):

# rpm -qf /usr/bin/gnome-system-log
gnome-utils-2.25.90-2.fc11.i386

How reproducible:

always

Steps to Reproduce:
1. invoke gnome-system-log from command line

  
Actual results:

[root@localhost ~]# gnome-system-log 
**
gnome-system-log:ERROR:logview-prefs.c:494:logview_prefs_store_fontsize: assertion failed: (fontsize > 0)
Aborted (core dumped)

Expected results:

shouldn't crash

Additional info:

[root@localhost ~]# gdb -q gnome-system-log
(gdb) run
Starting program: /usr/sbin/gnome-system-log 
[Thread debugging using libthread_db enabled]
Detaching after fork from child process 3398.
**
gnome-system-log:ERROR:logview-prefs.c:494:logview_prefs_store_fontsize: assertion failed: (fontsize > 0)

Program received signal SIGABRT, Aborted.
0x00881746 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
64	  return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);
Missing separate debuginfos, use: debuginfo-install expat-2.0.1-5.i386 gtk-nodoka-engine-0.7.2-2.fc11.i386 libXau-1.0.4-1.fc10.i386 libXcomposite-0.4.0-6.fc11.i386 libXcursor-1.1.9-3.fc10.i386 libXdamage-1.1.1-5.fc11.i386 libXfixes-4.0.3-4.fc10.i386 libXi-1.2.0-1.fc11.i386 libXinerama-1.0.3-2.fc10.i386 libXrandr-1.2.99.4-2.fc11.i386 libXrender-0.9.4-4.fc11.i386 libcap-2.10-2.fc10.i386 libpng-1.2.34-1.fc11.i386 libselinux-2.0.77-3.fc11.i386 libxcb-1.1.93-3.fc11.i386 pixman-0.14.0-1.fc11.i386
(gdb) bt
#0  0x00881746 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x008831b8 in abort () at abort.c:88
#2  0x00ab3163 in IA__g_assertion_message (domain=0x8059819 "gnome-system-log", file=0x805a7e6 "logview-prefs.c", line=494, 
    func=0x805aa82 "logview_prefs_store_fontsize", message=0x8154768 "assertion failed: (fontsize > 0)")
    at gtestutils.c:1301
#3  0x00ab36fd in IA__g_assertion_message_expr (domain=0x8059819 "gnome-system-log", file=0x805a7e6 "logview-prefs.c", 
    line=494, func=0x805aa82 "logview_prefs_store_fontsize", expr=0x805a7f6 "fontsize > 0") at gtestutils.c:1312
#4  0x08057e54 in logview_prefs_store_fontsize (prefs=0x8061518, fontsize=0) at logview-prefs.c:494
#5  0x08053855 in logview_set_fontsize () at logview-window.c:252
#6  0x0805420d in logview_window_init () at logview-window.c:1197
#7  0x00b72053 in IA__g_type_create_instance (type=134735992) at gtype.c:1674
#8  0x00b54f85 in g_object_constructor (type=134735992, n_construct_properties=2, construct_params=0x8091ca0)
    at gobject.c:1338
#9  0x00b557fb in IA__g_object_newv (object_type=134735992, n_parameters=0, parameters=0x0) at gobject.c:1215
#10 0x00b56417 in IA__g_object_new_valist (object_type=134735992, first_property_name=0x0, var_args=0xbffff6a8 "")
    at gobject.c:1278
#11 0x00b5658e in IA__g_object_new (object_type=134735992, first_property_name=0x0) at gobject.c:1060
#12 0x08052f3c in logview_window_new () at logview-window.c:1265
#13 0x080503a0 in logview_app_set_window (app=<value optimized out>) at logview-app.c:69
#14 logview_app_get () at logview-app.c:128
#15 0x08050678 in main (argc=1, argv=0xbffff7c4) at logview-main.c:104
(gdb) 

...attaching coredump
Comment 1 Matthias Clasen 2009-02-13 01:49:27 EST

*** This bug has been marked as a duplicate of bug 484770 ***

Note You need to log in before you can comment on or make changes to this bug.