Bug 485404 - Missing font dependency (xorg-x11-fonts-ISO8859-1-100dpi) in xpdf
Missing font dependency (xorg-x11-fonts-ISO8859-1-100dpi) in xpdf
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xpdf (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-13 07:20 EST by Haakon Riiser
Modified: 2009-03-05 11:35 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.02-12.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-05 11:34:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Haakon Riiser 2009-02-13 07:20:44 EST
xpdf uses fonts from xorg-x11-fonts-ISO8859-1-100dpi, but does not include this rpm in its dependencies.  The result is that I get error messages about missing fonts on startup.
Comment 1 François Cami 2009-03-02 16:31:09 EST
Haakon,

xpdf correctly pulls xorg-x11-fonts-ISO8859-1-75dpi but it
could happen if you use 100dpi, I suppose.

Could you post your xorg.conf as uncompressed text attachment ?

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Haakon Riiser 2009-03-04 09:57:38 EST
(In reply to comment #1)

> xpdf correctly pulls xorg-x11-fonts-ISO8859-1-75dpi but it
> could happen if you use 100dpi, I suppose.

Actually, xpdf didn't pull the 75dpi package before I reported a missing dependency (see bug 449298).

I recently noticed that the 100dpi package is required as well.  I probably didn't see this when I reported the 75dpi bug, because some other package had already pulled in the 100dpi package.

> Could you post your xorg.conf as uncompressed text attachment ?

Sure, but if all you want to know is my resolution, then I can tell you right now that I have set X to use 100 dpi exactly.  grep -i dpi /var/log/Xorg.0.log
produces

(**) NVIDIA(0): Option "UseEdidDpi" "False"
(**) NVIDIA(0): DPI set to (100, 100); computed from "DisplaySize" Monitor

Does this matter, though?  If xpdf might need 100 dpi fonts, they need to be included in the package dependencies.
Comment 3 François Cami 2009-03-04 16:23:09 EST
OK, switching to assigned.
Comment 4 Fedora Update System 2009-03-04 16:31:43 EST
xpdf-3.02-12.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xpdf-3.02-12.fc9
Comment 5 Fedora Update System 2009-03-04 16:31:48 EST
xpdf-3.02-12.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xpdf-3.02-12.fc10
Comment 6 Fedora Update System 2009-03-05 11:34:34 EST
xpdf-3.02-12.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2009-03-05 11:35:44 EST
xpdf-3.02-12.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.