Bug 485452 - File conflict between anjuta and gnome-build due to obsoletes issue
File conflict between anjuta and gnome-build due to obsoletes issue
Product: Fedora
Classification: Fedora
Component: anjuta (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
: Reopened
: 485877 495200 (view as bug list)
Depends On: 486530
  Show dependency treegraph
Reported: 2009-02-13 11:22 EST by Bruno Wolff III
Modified: 2009-04-13 01:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-04-13 01:03:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2009-02-13 11:22:05 EST
Description of problem:
In today's rawhide there is a file conflict which results in the following yum output:
Transaction Check Error:
  file /usr/bin/gbf-am-parse from install of anjuta-1:2.25.901-2.fc11.x86_64 conflicts with file from package gnome-build-2.24.1-1.fc10.x86_64
  file /usr/bin/gbf-mkfile-parse from install of anjuta-1:2.25.901-2.fc11.x86_64 conflicts with file from package gnome-build-2.24.1-1.fc10.x86_64

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Debarshi Ray 2009-02-14 03:52:39 EST
GNOME-Build has been merged with Anjuta 2.25.4. In Fedora, anjuta >= 1:2.25.901-1 obsoletes gnome-build.

Related to this is this ticket filed with the Release Engineering Team to block gnome-build: https://fedorahosted.org/rel-eng/ticket/1283
Comment 2 Bruno Wolff III 2009-02-14 10:00:05 EST
There may be something wrong with the obsoletes, otherwise I would have expected that updating to a version that obsoleted gnome-build would have resulted in the removal of gnome-build. If the obsoletes is correct, then maybe there is a yum issue.
Comment 3 Bruno Wolff III 2009-02-14 11:16:02 EST
I took a look at the spec file and the Obsoletes specification is incorrect.
The spec file uses:
Obsoletes: gnome-build <= 2.24.1-1
I think either of the following could be used:
Obsoletes: gnome-build <= 2.24.1
Obsoletes: gnome-build <= 2.24.1-1.fc10
Comment 4 Rakesh Pandit 2009-02-15 01:17:30 EST
http://fedoraproject.org/wiki/Packaging/NamingGuidelines has an example in "  Renaming/replacing existing packages " where it uses "Obsoletes: foo < 2:1.0-4" I tried with other options also but they all reproduce the conflict.

It seems to me the issue is some other place.
Comment 5 Bruno Wolff III 2009-02-15 09:27:10 EST
If "4" was the release that would be correct. However in this case the release of gnome-build is "1.fc10". "1.fc10" > "1" by rpms comparison method.
This results in gnome-build-2.24.1-1.fc10 > gnome-build-2.24.1-1 and not obsoleted by the current version on anjuta.
The file conflict is always going to be there if both packages are installed. You need to fix the obsoletes requirement so that the lastest version of gnome-build is obsoleted.
You also have the option to leave the release name off and only the name and version will be used. This is probably the better option in case there is another release in F10 before its end of life.
What other options did you try?
Did you actually try what I suggested?
Comment 6 Rakesh Pandit 2009-02-15 10:38:44 EST
I tried both one by one :

Obsoletes: gnome-build <= 2.24.1
Obsoletes: gnome-build <= 2.24.1-1.fc10

but on installing anjuta-*.rpm same conflicts are reproduced.
Comment 7 Bruno Wolff III 2009-02-15 15:23:30 EST
I have confirmed with Obsoletes: gnome-build <= 2.24.1 a local yum install doesn't remove gnome-build.
I suspect that something needs something provided by gnome-build that isn't provided by anjuta.
These are provided by gnome-build, but not anjuta:
gnome-build = 2.24.1-1.fc10
gnome-build(x86-32) = 2.24.1-1.fc10
perl(GBF::Make) = 2.24.1-1.fc10

libgbf-1.so.2 is required by anjuta and gnome-build. Same for libgbf-widgets-1.so.2. (Of stuff I have installed as I used rpm to do the check.)

I am going to do some further testing, but since builds of anjuta take a few minutes on my box I'll commit at least this much.
Comment 8 Bruno Wolff III 2009-02-15 15:33:21 EST
The old anjuta requires libgbf-1.so.2 and libgbf-widgets-1.so.2, but the new one doesn't. However the new one seems to require 'perl(GBF::Make)'. I'll see if I can do something to fudge that to see if that is what is blocking the replacement.
Comment 9 Bruno Wolff III 2009-02-15 16:37:40 EST
I added a bogus provides to provide perl(GBF::Make) and that didn't help.
I am now going to try taking the version off the Obsoletes to see if it is version related. (That shouldn't be done in a released version.)
I tried using the -v option on yum to see if that would indicate anything about its obsoletes handling, but it didn't yield any useful information.
Comment 10 Bruno Wolff III 2009-02-15 17:16:24 EST
It may be the testing process that is at issue. The yum documentation suggest that the obsoletes feature only works during an 'update'. When I was testing updating or install specifically the anjuta rpms I didn't see anything that indicated obsoletes processing was going on. I think that it may be to see the effects, anjuta has to have the new obsoletes value in the repo metadata for it to take effect.
I don't have the time now to try createrepo with a munged anjuta, but you might try it, or at least push one with the change and then it will be testable in rawhide. You need to push a change to fix the problem with perl(GBF::Make) in any case.
Comment 11 Rakesh Pandit 2009-02-17 03:58:28 EST
perl(GBF::Make) was earlier provided by gnome-build. After anjuta merged it .. they some how forgot to include perl module and that is why it is giving perl dependceny problem. Will patch it from upstream. They probably have fixed in cvs.

Will look into conflict also ASAP.
Comment 12 Rakesh Pandit 2009-02-17 04:00:52 EST
*** Bug 485877 has been marked as a duplicate of this bug. ***
Comment 13 Rakesh Pandit 2009-03-06 04:17:38 EST
This is solved now and in rawhide. I did tested it on my local rawhide box also. In case problem persist, please feel free to reopen.
Comment 14 Debarshi Ray 2009-04-11 13:39:05 EDT
Did we really fix this one?
Comment 15 Bruno Wolff III 2009-04-11 14:14:55 EDT
I gave up trying to retest it and just manually removed gnome-build a long time ago. I thought you would be able to easily retest it yourself and I didn't want to keep my system in a screwed up state waiting for a proper fix.
Make sure you have the .fc11 (or .fc10) as part of the release name in the obsoletes command.
Comment 16 Debarshi Ray 2009-04-11 14:19:14 EDT
*** Bug 495200 has been marked as a duplicate of this bug. ***
Comment 17 Debarshi Ray 2009-04-11 14:57:16 EDT
anjuta- really, really fixes this. Sorry for all the confusion
and delay.

Note You need to log in before you can comment on or make changes to this bug.