Bug 486530 - anjuta doesn't have matching "Provides: perl(GBF::Make)" for Requires, causing broken deps in rawhide
anjuta doesn't have matching "Provides: perl(GBF::Make)" for Requires, causin...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anjuta (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 485452
  Show dependency treegraph
 
Reported: 2009-02-20 01:39 EST by Alex Lancaster
Modified: 2009-02-26 17:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-26 17:01:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2009-02-20 01:39:02 EST
http://koji.fedoraproject.org/mash/rawhide-20090219/logs/depcheck

Broken deps for i386
----------------------------------------------------------
	1:anjuta-2.25.901-2.fc11.i386 requires perl(GBF::Make)

this appears to be because of a lack of matching Provides for perl(GBF::Make):

$ rpm -qip --requires /tmp/anjuta-2.25.901-2.fc11.i386.rpm |grep GBF
perl(GBF::AmFiles)  
perl(GBF::General)  
perl(GBF::Make)  

$ rpm -qip --provides /tmp/anjuta-2.25.901-2.fc11.i386.rpm |grep GBF
perl(GBF::AmFiles)  
perl(GBF::General)  

so there is something up with the autodep generation for the perl components.
Comment 1 Rakesh Pandit 2009-02-20 04:20:47 EST
Earlier gnome-build used to provide that (perl::Make) .. recently anjuta upstream merged it into anjuta, but they somehow seemed to have messed it up. There has been discussion going on upstream and it would hopefully be fixed sooner.

Debarshi may you have a look at it some time ... I will be away with no network access for next whole week.

Thank,
Comment 2 Debarshi Ray 2009-02-21 14:57:45 EST
First of all, we missed importing the following snippet from gnome-build.spec:

# Filter unwanted Provides.
cat << \EOF > %{name}-prov
#!/bin/sh
%{__perl_provides} $* |\
  sed -e '/perl(Make)/d' \
  -e '/perl(Make::Target)/d' \
  -e '/perl(Make::Rule::Vars)/d' \
  -e '/perl(Make::Rule)/d'
EOF

%define __perl_provides %{_builddir}/%{name}-%{version}/%{name}-prov
chmod +x %{__perl_provides}

# Filter unwanted Requires.
cat << \EOF > %{name}-req
#!/bin/sh
%{__perl_requires} $* |\
  sed -e '/perl(Make)/d' \
  -e '/perl(Make::Target)/d' \
  -e '/perl(Make::Rule::Vars)/d' \
  -e '/perl(Make::Rule)/d'
EOF

%define __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
chmod +x %{__perl_requires}

I am guessing this would fix this problem and I have committed the changes to CVS. Koji is down so can not build it yet.

I am without my F-10/Rawhide system due to a motherboard breakdown. So please let me know how this went.
Comment 3 Alex Lancaster 2009-02-25 03:20:41 EST
Nope, Jesse Keating rebuilt the package with the changes in CVS as part of the mass F-11 rebuild, but it failed :(

http://koji.fedoraproject.org/koji/buildinfo?buildID=84310
Comment 4 Alex Lancaster 2009-02-25 03:23:53 EST
Looks like missing BR.  Looking into it now.
Comment 5 Debarshi Ray 2009-02-25 03:30:57 EST
(In reply to comment #4)

> Looks like missing BR.  Looking into it now.

That is only one of the problems. Please follow the discussion on fedora-devel-list.
Comment 6 Alex Lancaster 2009-02-25 03:46:55 EST
In any case I fixed the missing BRs and committed to CVS, but it runs up against the Python issue mentioned on the list:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1168170

Sounds like you've got it under control, I'll leave to you now.
Comment 7 Debarshi Ray 2009-02-26 16:23:01 EST
(In reply to comment #2)

> First of all, we missed importing the following snippet from gnome-build.spec:
>
> [...]

And we also missed the explicit 'Provides: perl(GBF::Make)' in gnome-build.
Comment 8 Debarshi Ray 2009-02-26 17:01:01 EST
Fixed in anjuta-2.25.902-5.fc11.

Note You need to log in before you can comment on or make changes to this bug.