Bug 485505 - KDE4 doesn't start on ppc
KDE4 doesn't start on ppc
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
10
powerpc Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
http://forums.fedoraforum.org/showthr...
:
: 489542 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-13 14:52 EST by Israel Miranda
Modified: 2009-06-27 21:00 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-27 21:00:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Israel Miranda 2009-02-13 14:52:49 EST
Description of problem:

After installing Fedora 10, KDE doesn't start.
It starts loading, a progress bar is shown but after some seconds the screen goes back to display manager.

Version-Release number of selected component (if applicable):
KDE 4 available in Fedora 10 DVD and KDE 4.2 in testing-updates


How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 10 PPC on any ppc like computer
2. Install KDE4/ or choose KDE4 as desktop environment in installation process
3. Try to login in KDE4
  
Actual results:

Not possible to login in KDE4 with kwin window manager

Expected results:

Normal login without crash

Additional info:
Is possible to login in KDE4 with openbox window manager.
Just install openbox and choose KDE4/openbox in Display Manager.
Comment 1 Israel Miranda 2009-02-13 15:04:24 EST
At first, was thought that this bug could be a variant of this one https://bugzilla.redhat.com/show_bug.cgi?id=477095
But I tried the patch and it didn't work.
Comment 2 Kevin Kofler 2009-02-13 15:54:24 EST
What graphics hardware/driver?
Comment 3 Israel Miranda 2009-02-14 05:40:39 EST
Xorg identifies it as:
    Identifier  "Card0"
    Driver      "radeon"
    VendorName  "ATI Technologies Inc"
    BoardName   "RV350 [Mobility Radeon 9600 M10]"

But actually it is a 
ATI Mobility Radeon 9700:

  Chipset Model:	ATY,RV360M11
  Type:	Display
  Bus:	AGP
  VRAM (Total):	128 MB
  Vendor:	ATI (0x1002)

as detected by Mac Os System profiler.

I am using radeon driver.
Comment 4 Steven M. Parrish 2009-03-16 21:38:01 EDT
ping? is this another video driver issue that we can't resolve or something we need to look into.
Comment 5 Rex Dieter 2009-03-16 22:25:09 EDT
*** Bug 489542 has been marked as a duplicate of this bug. ***
Comment 6 Rex Dieter 2009-03-16 22:25:37 EDT
looks legit, now that we have multiple folks seeing this.
Comment 7 Steven M. Parrish 2009-04-27 14:34:09 EDT
Thank you for the bug report.  This issue needs to be addressed by the upstream developers.  Please submit a report at http://bugs.kde.org. You are requested to add the bugzilla link here for tracking purposes. Please make sure the bug isn't already in the upstream bug tracker before filing it.
Comment 8 Michal Smolak 2009-06-23 12:15:35 EDT
not specific for ppc architecture
Comment 9 Rex Dieter 2009-06-23 12:51:28 EDT
Re comment #8 , 
Can you elaborate ?
Comment 10 Peter Hedlund 2009-06-27 16:02:19 EDT
I have followed this bug during the Fedora 10 cycle. Now, with an up-to-date Fedora 11 installation KDE works fine on my PowerBook G4.

My only wish right now is an update to Qt 4.5.2 since it fixes the inverted colors on icons.
Comment 11 Michal Smolak 2009-06-27 16:33:23 EDT
Kde works perfectly only with GDM.  When KDM is used it won´t start. I have Fedora 11 x86-64 on HP6910p notebook.
Comment 12 Kevin Kofler 2009-06-27 18:10:13 EDT
> My only wish right now is an update to Qt 4.5.2 since it fixes the inverted
> colors on icons.

We're working on that. It has already hit Rawhide, we'll be preparing builds for updates-testing shortly.
Comment 13 Peter Hedlund 2009-06-27 20:57:33 EDT
(In reply to comment #11)
> Kde works perfectly only with GDM.  When KDM is used it won´t start. I have
> Fedora 11 x86-64 on HP6910p notebook.  

I know this does not help you, but I use kdm successfully on one ppc and two x86_64 machines.
Comment 14 Rex Dieter 2009-06-27 21:00:45 EDT
Woo, OK, let's consider this general kde4/ppc problem solved.

Any new/different ppc-related issues (like comment #11), please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.