Bug 489542 - can't log in to kde session (ppc)
can't log in to kde session (ppc)
Status: CLOSED DUPLICATE of bug 485505
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
10
powerpc Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-10 12:32 EDT by Robert Story
Modified: 2009-03-16 22:25 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 22:25:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.xsession-errors (7.32 KB, text/plain)
2009-03-10 12:32 EDT, Robert Story
no flags Details

  None (edit)
Description Robert Story 2009-03-10 12:32:47 EDT
Created attachment 334673 [details]
.xsession-errors

Description of problem:
when I try to log in to a KDE session, the progress bar gets to about 80%, then the screen goes black and I get dumped back to the login screen. I tried both GDM and KDM.

Version-Release number of selected component (if applicable):
not really sure who is at fault, so I can't say...

How reproducible:
every time

Steps to Reproduce:
1. install f10 w/all updates
2. set login session to KDE
3. log in
  
Actual results:
crash

Expected results:
log in

Additional info:
NOTE WELL: this is PPC hardware.

after switching to a VT and setting 'exec startkde' in .xinitrc, I can run 'startx -- :2' and get a KDE session.  I also did a fresh install and installed LDX or whatever, and if I select a session type of Openbox/KDE, I can log in successfully.
Comment 1 Kevin Kofler 2009-03-10 15:17:51 EDT
"Fatal IO error: client killed" means X11 crashed. What's the video driver you're using?
Comment 2 Robert Story 2009-03-10 15:28:02 EDT
I have no xorg.conf, but according to Xorg.0.log it is autoselecting ati.

Card is ATI RV350 [Mobility Radeon 9600 M10] rev 0.  The machine is a PowerBook G4 (aluminum).
Comment 3 Rex Dieter 2009-03-11 12:21:28 EDT
Interesting, mind trying booting with some combination of the following grub/boot options:
nomodeset
xdriver=vesa

?
Comment 4 Robert Story 2009-03-11 13:15:19 EDT
I tried all 4 combinations, with the same result.
Comment 5 Rex Dieter 2009-03-11 13:36:15 EDT
By the evidence gathered so far, it's either kwin or dbus crashing (more likely the former, since openbox seems to work fine here).
Comment 6 Steven M. Parrish 2009-03-16 22:07:30 EDT
Thank you for the bug report.  This issue needs to be addressed by the upstream developers.  Please submit a report at http://bugs.kde.org. You are requested to add the bugzilla link here for tracking purposes. Please make sure the bug isn't already in the upstream bug tracker before filing it.
Comment 7 Rex Dieter 2009-03-16 22:25:09 EDT

*** This bug has been marked as a duplicate of bug 485505 ***

Note You need to log in before you can comment on or make changes to this bug.