Bug 485547 - Volume lowers after several clips. Just touching the speaker icon fixes...
Volume lowers after several clips. Just touching the speaker icon fixes...
Status: CLOSED DUPLICATE of bug 486455
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-13 22:23 EST by Tom London
Modified: 2009-03-23 14:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-23 14:31:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gzipped ~/.xsession-errors (58.59 KB, application/x-gzip)
2009-02-18 19:42 EST, Tom London
no flags Details

  None (edit)
Description Tom London 2009-02-13 22:23:35 EST
Description of problem:
After installing rhythmbox-0.11.6-24.r6096.fc11.x86_64, I've noticed that the perceived loudness of played music from rhythmbox suddenly goes down.

Just clicking on the "speaker icon" makes it go up again.

Version-Release number of selected component (if applicable):
rhythmbox-0.11.6-24.r6096.fc11.x86_64

How reproducible:
Quite often.  Don't know what triggers this....

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bastien Nocera 2009-02-16 04:56:16 EST
Does this happen with rhythmbox-0.11.6-23.r6096?

I guess it could be a side-effect of my patch to have Rhythmbox modify the stream volume instead of its internal one.
Comment 2 Tom London 2009-02-16 10:53:01 EST
I've reverted to rhythmbox-0.11.6-23.r6096.fc11.x86_64.rpm and am testing....

What would happen is the volume level as reported by the volume icon in rhythmbox would "drift down", and (I think) the volume level as reported by gnome-volume-control applet would change.

I set both to "full volume" (with rhythmbox-0.11.6-24.r6096.fc11.x86_64.rpm), and I think that seemed to stay constant for awhile.

Anyway, I'm running rhythmbox-0.11.6-23.r6096.fc11.x86_64.rpm now with both reporting 96%.

I'll let this run for a while.  If this "works", I'll update back to -24 and see if I can localize this a bit more.....
Comment 3 Tom London 2009-02-16 14:39:43 EST
Had some funny-ness after reverting and updating to newest gstreamer-plugins-good, so I updated everything to latest again.

I did notice a "conflict" of sorts between gnome-volume-control and pavucontrol (pavucontrol-0.9.7-3.fc10.x86_64).  Has pavucontrol been 'removed'?
Comment 4 Tom London 2009-02-16 14:42:18 EST
Probably a stupid question, but if I run both rhythmbox and audacity (cycling back and forth between them), will audacity fiddle with the volume and affect rhythmbox?
Comment 5 Tom London 2009-02-16 21:02:10 EST
Just playing rhythmbox, in 15 minutes (not running any other sound programs) the sound level displayed by placing the cursor over the gnome-sound-control-applet icon went from 85%->81%.  It started (some while ago) at 95%.
Comment 6 Tom London 2009-02-18 09:45:50 EST
Another interesting data point:

I'm running latest rawhide.

With rhythmbox playing a clip, I got a 'pidgin arrival/departure sound'. At the completion of the pidgin sound, rhythmbox's sound was completely muted, and the gnome-volume-control icon showed "muted", that is, it displayed the little "red x" on the icon.

Sound level in both gnome-volume-control and rhythmbox show muted/zero.

I clicked on gnome-volume-control's applet and restored it to 98%.  No sound.

I clicked on rhythmbox's volume control and restored it to 90%: sound returned.

Perhaps there could there be a race in rhythmbox's handling of pulseaudio volume?  Something else?

[root@tlondon ~]# rpm -q rhythmbox
rhythmbox-0.11.6-25.r6096.fc11.x86_64
[root@tlondon ~]#
Comment 7 Tom London 2009-02-18 09:48:51 EST
I forgot to mention that I muted sound in pidgin before I fiddled with restoring the sound abovew.

BTW, after restoring as above, and allowing rhythmbox to continue to play, gnome-volume-control's "level" now says 95% after 10 minutes, so it "lost" 3% in 10 minutes.
Comment 8 Tom London 2009-02-18 19:42:00 EST
Created attachment 332486 [details]
gzipped ~/.xsession-errors

Not sure it relevant, but I'm attaching my ~/.xsession-errors.

There are over 14K instances of messages like:

** (gnome-volume-control-applet:4728): DEBUG: Updating source: index=1 name='alsa_input.pci_8086_293e_sound_card_0' description='HDA Intel - CONEXANT Analog'
** (gnome-volume-control-applet:4728): DEBUG: Updating source: index=1 name='alsa_input.pci_8086_293e_sound_card_0' description='HDA Intel - CONEXANT Analog'
** (gnome-volume-control-applet:4728): DEBUG: Updating client: index=674 name='Native client (UNIX socket client)'
** (gnome-volume-control-applet:4728): DEBUG: Updating client: index=674 name='ALSA plug-in [audacity]'
** (gnome-volume-control-applet:4728): DEBUG: Updating source output: index=202 name='ALSA Capture' client=674 source=1
** (gnome-volume-control-applet:4728): DEBUG: Updating source: index=1 name='alsa_input.pci_8086_293e_sound_card_0' description='HDA Intel - CONEXANT Analog'
** (gnome-volume-control-applet:4728): DEBUG: Updating source: index=1 name='alsa_input.pci_8086_293e_sound_card_0' description='HDA Intel - CONEXANT Analog'
** (gnome-volume-control-applet:4728): DEBUG: Updating client: index=675 name='Native client (UNIX socket client)'
** (gnome-volume-control-applet:4728): DEBUG: Updating client: index=675 name='ALSA plug-in [audacity]'
** (gnome-volume-control-applet:4728): DEBUG: Updating source output: index=203 name='ALSA Capture' client=675 source=1
Comment 9 Tom London 2009-02-20 12:38:24 EST
An interesting factiod:

If both gnome-volume-control-applet and rhythmbox have their volume settings at maximum (or 100%), the volume does not change/go down...
Comment 10 Tom London 2009-02-20 16:48:48 EST
One more factoid:

If rhythmbox's volume is set to "Full Volume", then the volume doesn't go down either.

Appears to only happen if rhythmbox's volume setting is at less than "full".
Comment 11 antonio montagnani 2009-02-22 04:03:26 EST
rhythmbox-0.11.6-26.r6096.fc11.i586 has same problem on two systems out of my two F11 systems....
Comment 12 Matthias Clasen 2009-03-12 12:23:55 EDT
I assume this might just be a duplicate of bug 486455, which was recently closed as fixed in current rawhide. Do people here still see this issue ?
Comment 13 Bastien Nocera 2009-03-23 14:31:36 EDT
Nobody complaining, closing as a dupe. Reopen if the problem persists (you might also want to upgrade to rhythmbox 0.12.0 as well).

*** This bug has been marked as a duplicate of bug 486455 ***

Note You need to log in before you can comment on or make changes to this bug.